blob: ba4f4062d08c977afb3a8aed0d7ef9e010d0ab3c [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Weston, a Wayland compositor"
2DESCRIPTION = "Weston is the reference implementation of a Wayland compositor"
3HOMEPAGE = "http://wayland.freedesktop.org"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d79ee9e66bb0f95d3386a7acae780b70 \
6 file://libweston/compositor.c;endline=27;md5=eb6d5297798cabe2ddc65e2af519bcf0 \
7 "
8
9SRC_URI = "https://gitlab.freedesktop.org/wayland/weston/-/releases/${PV}/downloads/${BPN}-${PV}.tar.xz \
10 file://weston.png \
11 file://weston.desktop \
12 file://xwayland.weston-start \
13 file://systemd-notify.weston-start \
14 "
15
Patrick Williams2390b1b2022-11-03 13:47:49 -050016SRC_URI[sha256sum] = "a6138d4dc9554560ac304312df456019f4be025ec79130f05fb5f2e41c091e1d"
Patrick Williams92b42cb2022-09-03 06:53:57 -050017
18UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
19UPSTREAM_CHECK_REGEX = "weston-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
20
21inherit meson pkgconfig useradd
22
23# depends on virtual/egl
24#
25require ${THISDIR}/required-distro-features.inc
26
27DEPENDS = "libxkbcommon gdk-pixbuf pixman cairo glib-2.0"
28DEPENDS += "wayland wayland-protocols libinput virtual/egl pango wayland-native"
29
30LDFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'lto', '-Wl,-z,undefs', '', d)}"
31
32WESTON_MAJOR_VERSION = "${@'.'.join(d.getVar('PV').split('.')[0:1])}"
33
34EXTRA_OEMESON += "-Dpipewire=false"
35
36PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'kms wayland egl clients', '', d)} \
37 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 wayland', 'xwayland', '', d)} \
38 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd x11', d)} \
39 ${@bb.utils.contains_any('DISTRO_FEATURES', 'wayland x11', '', 'headless', d)} \
40 ${@oe.utils.conditional('VIRTUAL-RUNTIME_init_manager', 'sysvinit', 'launcher-libseat', '', d)} \
41 image-jpeg \
42 screenshare \
43 shell-desktop \
44 shell-fullscreen \
45 shell-ivi"
46
47# Can be 'damage', 'im', 'egl', 'shm', 'touch', 'dmabuf-feedback', 'dmabuf-v4l', 'dmabuf-egl' or 'all'
48SIMPLECLIENTS ?= "all"
49
50#
51# Compositor choices
52#
53# Weston on KMS
54PACKAGECONFIG[kms] = "-Dbackend-drm=true,-Dbackend-drm=false,drm udev virtual/egl virtual/libgles2 virtual/libgbm mtdev"
55# Weston on Wayland (nested Weston)
56PACKAGECONFIG[wayland] = "-Dbackend-wayland=true,-Dbackend-wayland=false,virtual/egl virtual/libgles2"
57# Weston on X11
58PACKAGECONFIG[x11] = "-Dbackend-x11=true,-Dbackend-x11=false,virtual/libx11 libxcb libxcb libxcursor cairo"
59# Headless Weston
60PACKAGECONFIG[headless] = "-Dbackend-headless=true,-Dbackend-headless=false"
Patrick Williams92b42cb2022-09-03 06:53:57 -050061# Weston on RDP
62PACKAGECONFIG[rdp] = "-Dbackend-rdp=true,-Dbackend-rdp=false,freerdp"
Patrick Williams92b42cb2022-09-03 06:53:57 -050063# VA-API desktop recorder
64PACKAGECONFIG[vaapi] = "-Dbackend-drm-screencast-vaapi=true,-Dbackend-drm-screencast-vaapi=false,libva"
65# Weston with EGL support
66PACKAGECONFIG[egl] = "-Drenderer-gl=true,-Drenderer-gl=false,virtual/egl"
67# Weston with lcms support
68PACKAGECONFIG[lcms] = "-Dcolor-management-lcms=true,-Dcolor-management-lcms=false,lcms"
69# Weston with webp support
70PACKAGECONFIG[webp] = "-Dimage-webp=true,-Dimage-webp=false,libwebp"
71# Weston with systemd-login support
72PACKAGECONFIG[systemd] = "-Dsystemd=true -Dlauncher-logind=true,-Dsystemd=false -Dlauncher-logind=false,systemd dbus"
73# Weston with Xwayland support (requires X11 and Wayland)
74PACKAGECONFIG[xwayland] = "-Dxwayland=true,-Dxwayland=false"
75# colord CMS support
Patrick Williams2390b1b2022-11-03 13:47:49 -050076PACKAGECONFIG[colord] = "-Ddeprecated-color-management-colord=true,-Ddeprecated-color-management-colord=false,colord"
Patrick Williams92b42cb2022-09-03 06:53:57 -050077# Clients support
78PACKAGECONFIG[clients] = "-Dsimple-clients=${SIMPLECLIENTS} -Ddemo-clients=true,-Dsimple-clients= -Ddemo-clients=false"
79# Virtual remote output with GStreamer on DRM backend
80PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0 gstreamer1.0-plugins-base"
81# Weston with screen-share support
82PACKAGECONFIG[screenshare] = "-Dscreenshare=true,-Dscreenshare=false"
83# Traditional desktop shell
84PACKAGECONFIG[shell-desktop] = "-Dshell-desktop=true,-Dshell-desktop=false"
85# Fullscreen shell
86PACKAGECONFIG[shell-fullscreen] = "-Dshell-fullscreen=true,-Dshell-fullscreen=false"
87# In-Vehicle Infotainment (IVI) shell
88PACKAGECONFIG[shell-ivi] = "-Dshell-ivi=true,-Dshell-ivi=false"
89# JPEG image loading support
90PACKAGECONFIG[image-jpeg] = "-Dimage-jpeg=true,-Dimage-jpeg=false, jpeg"
91# support libseat based launch
92PACKAGECONFIG[launcher-libseat] = "-Dlauncher-libseat=true,-Dlauncher-libseat=false,seatd"
93
94do_install:append() {
95 # Weston doesn't need the .la files to load modules, so wipe them
96 rm -f ${D}/${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.la
97
98 # If X11, ship a desktop file to launch it
99 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then
100 install -d ${D}${datadir}/applications
101 install ${WORKDIR}/weston.desktop ${D}${datadir}/applications
102
103 install -d ${D}${datadir}/icons/hicolor/48x48/apps
104 install ${WORKDIR}/weston.png ${D}${datadir}/icons/hicolor/48x48/apps
105 fi
106
107 if [ "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', 'yes', 'no', d)}" = "yes" ]; then
108 install -Dm 644 ${WORKDIR}/xwayland.weston-start ${D}${datadir}/weston-start/xwayland
109 fi
110
111 if [ "${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'yes', 'no', d)}" = "yes" ]; then
112 install -Dm 644 ${WORKDIR}/systemd-notify.weston-start ${D}${datadir}/weston-start/systemd-notify
113 fi
114
115 if [ "${@bb.utils.contains('PACKAGECONFIG', 'launch', 'yes', 'no', d)}" = "yes" ]; then
116 chmod u+s ${D}${bindir}/weston-launch
117 fi
118}
119
120PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \
121 libweston-${WESTON_MAJOR_VERSION} ${PN}-examples"
122
123FILES:${PN}-dev += "${libdir}/${BPN}/libexec_weston.so"
124FILES:${PN} = "${bindir}/weston ${bindir}/weston-terminal ${bindir}/weston-info ${bindir}/weston-launch ${bindir}/wcap-decode ${libexecdir} ${libdir}/${BPN}/*.so* ${datadir}"
125
126FILES:libweston-${WESTON_MAJOR_VERSION} = "${libdir}/lib*${SOLIBS} ${libdir}/libweston-${WESTON_MAJOR_VERSION}/*.so"
127SUMMARY:libweston-${WESTON_MAJOR_VERSION} = "Helper library for implementing 'wayland window managers'."
128
129FILES:${PN}-examples = "${bindir}/*"
130
131FILES:${PN}-xwayland = "${libdir}/libweston-${WESTON_MAJOR_VERSION}/xwayland.so"
132RDEPENDS:${PN}-xwayland += "xwayland"
133
134RDEPENDS:${PN} += "xkeyboard-config"
135RRECOMMENDS:${PN} = "weston-init liberation-fonts"
136RRECOMMENDS:${PN}-dev += "wayland-protocols"
137
138USERADD_PACKAGES = "${PN}"
139GROUPADD_PARAM:${PN} = "--system weston-launch"