blob: 9ff196c897fbb9f99cf730271bf45cc8f68b2475 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Xlib: C Language X Interface library"
2
3DESCRIPTION = "This package provides a client interface to the X Window \
4System, otherwise known as 'Xlib'. It provides a complete API for the \
5basic functions of the window system."
6
7require xorg-lib-common.inc
8
9FILESEXTRAPATHS =. "${FILE_DIRNAME}/libx11:"
10
11PE = "1"
12
13# temporarily override SRC_URI which is hard-coded in xorg-lib-common.inc
14# since new versions of packages use a new compression format - .tar.gz
15SRC_URI = "${XORG_MIRROR}/individual/lib/${XORG_PN}-${PV}.tar.xz"
16
17SRC_URI += "file://disable_tests.patch \
Patrick Williams2390b1b2022-11-03 13:47:49 -050018 file://0001-fix-a-memory-leak-in-XRegisterIMInstantiateCallback.patch \
Andrew Geissler595f6302022-01-24 19:11:47 +000019 "
Andrew Geissler615f2f12022-07-15 14:00:58 -050020SRC_URI[sha256sum] = "1bc41aa1bbe01401f330d76dfa19f386b79c51881c7bbfee9eb4e27f22f2d9f7"
Andrew Geissler595f6302022-01-24 19:11:47 +000021
22PROVIDES = "virtual/libx11"
23
24XORG_PN = "libX11"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000025LICENSE = "MIT & MIT & BSD-1-Clause & HPND & HPND-sell-variant"
Andrew Geissler595f6302022-01-24 19:11:47 +000026LIC_FILES_CHKSUM = "file://COPYING;md5=172255dee66bb0151435b2d5d709fcf7"
27
28DEPENDS += "xorgproto \
29 xtrans \
30 libxcb \
31 xorgproto-native \
32 autoconf-archive \
33 "
34
35EXTRA_OECONF += "--with-keysymdefdir=${STAGING_INCDIR}/X11/ --disable-xf86bigfont"
36EXTRA_OEMAKE += 'CWARNFLAGS=""'
37
38PACKAGECONFIG ??= "xcms"
39PACKAGECONFIG[xcms] = "--enable-xcms,--disable-xcms"
40
41PACKAGES =+ "${PN}-xcb"
42
43inherit gettext
44
45FILES:${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB ${datadir}/X11/Xcms.txt"
46FILES:${PN}-xcb += "${libdir}/libX11-xcb.so.*"
47FILES:${PN}-locale += "${datadir}/X11/locale ${libdir}/X11/locale"
48
49BBCLASSEXTEND = "native nativesdk"