blob: 92ec954df25fd9678c0f984a4ae0bbcd7d5d3ee8 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "XDMCP: X Display Manager Control Protocol library"
2
3DESCRIPTION = "The purpose of the X Display Manager Control Protocol \
4(XDMCP) is to provide a uniform mechanism for an autonomous display to \
5request login service from a remote host. An X terminal (screen, \
6keyboard, mouse, processor, network interface) is a prime example of an \
7autonomous display."
8
9require xorg-lib-common.inc
10
11inherit gettext
12
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000013LICENSE = "MIT"
Brad Bishopc342db32019-05-15 21:57:59 -040014LIC_FILES_CHKSUM = "file://COPYING;md5=d559fb26e129626022e052a5e6e0e123"
15
16DEPENDS += "xorgproto"
17PROVIDES = "xdmcp"
18
19PE = "1"
20
21XORG_PN = "libXdmcp"
22
23BBCLASSEXTEND = "native nativesdk"
24
25SRC_URI[md5sum] = "115c5c12ecce0e749cd91d999a5fd160"
26SRC_URI[sha256sum] = "20523b44aaa513e17c009e873ad7bbc301507a3224c232610ce2e099011c6529"
27
28PACKAGECONFIG ??= ""
29PACKAGECONFIG[arc4] = "ac_cv_lib_bsd_arc4random_buf=yes,ac_cv_lib_bsd_arc4random_buf=no,libbsd"