blob: f3e1adee70573f6256f6d9dc933a8a356433e04b [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "https://www.webkitgtk.org/"
3BUGTRACKER = "https://bugs.webkit.org/"
4
5LICENSE = "BSD-2-Clause & LGPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
9 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
10 "
11
12SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
13 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
14 file://0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch \
15 file://0001-Fix-build-without-opengl-or-es.patch \
16 file://reproducibility.patch \
17 file://0001-When-building-introspection-files-do-not-quote-CFLAG.patch \
Andrew Geissler87f5cff2022-09-30 13:13:31 -050018 file://fix-gstreamer-include-paths.patch \
19 file://0d3344e17d258106617b0e6d783d073b188a2548.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050020 "
Andrew Geissler87f5cff2022-09-30 13:13:31 -050021SRC_URI[sha256sum] = "0c260cf2b32f0481d017670dfed1b61e554967cd067195606c9f9eb5fe731743"
Patrick Williams92b42cb2022-09-03 06:53:57 -050022
23inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gtk-doc
24
25ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
26REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'opengl', '', d)}"
27
28CVE_PRODUCT = "webkitgtk webkitgtk\+"
29
30DEPENDS = " \
31 ruby-native \
32 gperf-native \
33 cairo \
34 harfbuzz \
35 jpeg \
36 atk \
37 libwebp \
38 gtk+3 \
39 libxslt \
40 libtasn1 \
41 libnotify \
42 gstreamer1.0 \
43 gstreamer1.0-plugins-base \
44 "
45
Patrick Williams7784c422022-11-17 07:29:11 -060046PACKAGECONFIG_SOUP ?= "soup3"
Patrick Williams92b42cb2022-09-03 06:53:57 -050047PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd wayland x11', d)} \
48 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'webgl opengl', '', d)} \
49 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'webgl gles2', d)} \
50 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'opengl-or-es', '', d)} \
51 enchant \
52 libsecret \
53 ${PACKAGECONFIG_SOUP} \
54 "
55
56PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland libwpe wpebackend-fdo wayland-native"
57PACKAGECONFIG[angle] = "-DUSE_ANGLE_WEBGL=ON,-DUSE_ANGLE_WEBGL=OFF"
58PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11 libxcomposite libxdamage libxrender libxt"
59PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
60PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant2"
61PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
62PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/egl"
63PACKAGECONFIG[opengl] = "-DENABLE_GRAPHICS_CONTEXT_GL=ON,-DENABLE_GRAPHICS_CONTEXT_GL=OFF,virtual/egl"
64PACKAGECONFIG[opengl-or-es] = "-DUSE_OPENGL_OR_ES=ON,-DUSE_OPENGL_OR_ES=OFF"
65PACKAGECONFIG[libsecret] = "-DUSE_LIBSECRET=ON,-DUSE_LIBSECRET=OFF,libsecret"
66PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
67PACKAGECONFIG[woff2] = "-DUSE_WOFF2=ON,-DUSE_WOFF2=OFF,woff2"
68PACKAGECONFIG[openjpeg] = "-DUSE_OPENJPEG=ON,-DUSE_OPENJPEG=OFF,openjpeg"
69PACKAGECONFIG[systemd] = "-DUSE_SYSTEMD=ON,-DUSE_SYSTEMD=off,systemd"
70PACKAGECONFIG[reduce-size] = "-DCMAKE_BUILD_TYPE=MinSizeRel,-DCMAKE_BUILD_TYPE=Release,,"
71PACKAGECONFIG[lcms] = "-DUSE_LCMS=ON,-DUSE_LCMS=OFF,lcms"
72PACKAGECONFIG[soup2] = "-DUSE_SOUP2=ON,-DUSE_SOUP2=OFF,libsoup-2.4,,,soup3"
73PACKAGECONFIG[soup3] = ",,libsoup,,,soup2"
74PACKAGECONFIG[journald] = "-DENABLE_JOURNALD_LOG=ON,-DENABLE_JOURNALD_LOG=OFF,systemd"
75
76# webkitgtk is full of /usr/bin/env python, particular for generating docs
77do_configure[postfuncs] += "setup_python_link"
78setup_python_link() {
79 if [ ! -e ${STAGING_BINDIR_NATIVE}/python ]; then
80 ln -s `which python3` ${STAGING_BINDIR_NATIVE}/python
81 fi
82}
83
84EXTRA_OECMAKE = " \
85 -DPORT=GTK \
86 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
87 ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '-DENABLE_GTKDOC=ON', '-DENABLE_GTKDOC=OFF', d)} \
88 -DENABLE_MINIBROWSER=ON \
89 -DPYTHON_EXECUTABLE=`which python3` \
90 -DENABLE_BUBBLEWRAP_SANDBOX=OFF \
91 -DENABLE_GAMEPAD=OFF \
92 "
93
94# Javascript JIT is not supported on ARC
95EXTRA_OECMAKE:append:arc = " -DENABLE_JIT=OFF "
96# By default 25-bit "medium" calls are used on ARC
97# which is not enough for binaries larger than 32 MiB
98CFLAGS:append:arc = " -mlong-calls"
99CXXFLAGS:append:arc = " -mlong-calls"
100
101# Needed for non-mesa graphics stacks when x11 is disabled
102CXXFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', '-DEGL_NO_X11=1', d)}"
103
104# Javascript JIT is not supported on powerpc
105EXTRA_OECMAKE:append:powerpc = " -DENABLE_JIT=OFF "
106EXTRA_OECMAKE:append:powerpc64 = " -DENABLE_JIT=OFF "
107
108# ARM JIT code does not build on ARMv4/5/6 anymore
109EXTRA_OECMAKE:append:armv5 = " -DENABLE_JIT=OFF "
110EXTRA_OECMAKE:append:armv6 = " -DENABLE_JIT=OFF "
111EXTRA_OECMAKE:append:armv4 = " -DENABLE_JIT=OFF "
112
113EXTRA_OECMAKE:append:mipsarch = " -DUSE_LD_GOLD=OFF "
114EXTRA_OECMAKE:append:powerpc = " -DUSE_LD_GOLD=OFF "
115
116# JIT and gold linker does not work on RISCV
117EXTRA_OECMAKE:append:riscv32 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
118EXTRA_OECMAKE:append:riscv64 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
119
120# JIT not supported on MIPS either
121EXTRA_OECMAKE:append:mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
122
123# JIT not supported on X32
124# An attempt was made to upstream JIT support for x32 in
125# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
126# unresolved due to limited X32 adoption.
127EXTRA_OECMAKE:append:x86-x32 = " -DENABLE_JIT=OFF "
128
129SECURITY_CFLAGS:remove:aarch64 = "-fpie"
130SECURITY_CFLAGS:append:aarch64 = " -fPIE"
131
132FILES:${PN} += "${libdir}/webkit2gtk-4.*/injected-bundle/libwebkit2gtkinjectedbundle.so"
133
134RRECOMMENDS:${PN} += "ca-certificates shared-mime-info"
135
136# http://errors.yoctoproject.org/Errors/Details/20370/
137ARM_INSTRUCTION_SET:armv4 = "arm"
138ARM_INSTRUCTION_SET:armv5 = "arm"
139ARM_INSTRUCTION_SET:armv6 = "arm"
140
141# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
142# https://bugs.webkit.org/show_bug.cgi?id=159880
143# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
144# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
145ARM_INSTRUCTION_SET:armv7a = "thumb"
146ARM_INSTRUCTION_SET:armv7r = "thumb"
147ARM_INSTRUCTION_SET:armv7ve = "thumb"
148
149# introspection inside qemu-arm hangs forever on musl/arm builds
150# therefore disable GI_DATA
151GI_DATA_ENABLED:libc-musl:armv7a = "False"
152GI_DATA_ENABLED:libc-musl:armv7ve = "False"
153
154# Can't be built with ccache
155CCACHE_DISABLE = "1"
156
157PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess"
158src_package_preprocess () {
159 # Trim build paths from comments in generated sources to ensure reproducibility
160 sed -i -e "s,${WORKDIR},,g" \
161 ${B}/JavaScriptCore/DerivedSources/*.h \
162 ${B}/JavaScriptCore/DerivedSources/yarr/*.h \
163 ${B}/JavaScriptCore/PrivateHeaders/JavaScriptCore/*.h \
164 ${B}/WebKit2Gtk/DerivedSources/webkit2/*.cpp \
165 ${B}/WebKit2Gtk/DerivedSources/webkit2/*.h
166
167}
168