blob: 5d634b80737520e43cbb6a994e0a50064219ab7d [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "in-depth comparison of files, archives, and directories"
2DESCRIPTION = "Tries to get to the bottom of what makes files or directories \
3different. It will recursively unpack archives of many kinds and transform \
4various binary formats into more human-readable form to compare them. \
5It can compare two tarballs, ISO images, or PDF just as easily."
6HOMEPAGE = "https://diffoscope.org/"
7BUGTRACKER = "https://salsa.debian.org/reproducible-builds/diffoscope/-/issues"
8LICENSE = "GPL-3.0-or-later"
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11PYPI_PACKAGE = "diffoscope"
12
13inherit pypi setuptools3
14
Patrick Williams7784c422022-11-17 07:29:11 -060015SRC_URI[sha256sum] = "1920ebdca40e85f019a84e0220e4a79f00ffdafc0f78e1f1e2219123d5c08dfb"
Patrick Williams92b42cb2022-09-03 06:53:57 -050016
17RDEPENDS:${PN} += "binutils vim squashfs-tools python3-libarchive-c python3-magic python3-rpm"
18
19# Dependencies don't build for musl
20COMPATIBLE_HOST:libc-musl = 'null'
21
22do_install:append:class-native() {
23 create_wrapper ${D}${bindir}/diffoscope \
24 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
25 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
26 LD_LIBRARY_PATH=${STAGING_LIBDIR_NATIVE} \
27 RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE}
28}
29
30BBCLASSEXTEND = "native"