blob: f6ecb9aec4b165849281cd6bc40a2d9665f21175 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Easy API to create and parse X.509 and CMS related objects"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "A library to make the tasks of working with X.509 certificates, \
3CMS data and related objects more easy. It provides a highlevel interface to \
4the implemented protocols and presents the data in a consistent way. The \
5library does not rely on another cryptographic library but provides \
6hooks for easy integration with Libgcrypt. "
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007HOMEPAGE = "http://www.gnupg.org/related_software/libksba/"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008LICENSE = "GPL-3.0-or-later & (GPL-2.0-or-later | LGPL-3.0-or-later)"
9LICENSE:${PN} = "GPL-2.0-or-later | LGPL-3.0-or-later"
10LICENSE:${PN}-doc = "GPL-3.0-or-later"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050011LIC_FILES_CHKSUM = "file://COPYING;md5=fd541d83f75d038c4e0617b672ed8bda \
12 file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
13 file://COPYING.GPLv3;md5=2f31b266d3440dd7ee50f92cf67d8e6c \
14 file://COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
15 "
16
17DEPENDS = "libgpg-error"
18
19BINCONFIG = "${bindir}/ksba-config"
20
21inherit autotools binconfig-disabled pkgconfig texinfo
22
23UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
24SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
25 file://ksba-add-pkgconfig-support.patch"
26
Patrick Williams2390b1b2022-11-03 13:47:49 -050027SRC_URI[sha256sum] = "fce01ccac59812bddadffacff017dac2e4762bdb6ebc6ffe06f6ed4f6192c971"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028
Patrick Williams213cb262021-08-07 19:21:33 -050029do_configure:prepend () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050030 # Else these could be used in preference to those in aclocal-copy
31 rm -f ${S}/m4/gpg-error.m4
32}
Brad Bishop316dfdd2018-06-25 12:45:53 -040033
Brad Bishop1d80a2e2019-11-15 16:35:03 -050034BBCLASSEXTEND = "native nativesdk"