Yuxiao Zhang | bd01c3b | 2024-01-24 16:25:21 -0800 | [diff] [blame] | 1 | SUMMARY = "Disable ipmi kcs while in Guest Os" |
| 2 | DESCRIPTION = "Disable ipmi kcs while an untrusted host OS is running" |
| 3 | PR = "r1" |
| 4 | |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 7 | |
| 8 | inherit systemd |
| 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://disable-ipmi-kcs.service.in \ |
| 12 | " |
| 13 | |
| 14 | DEPENDS += "systemd" |
| 15 | |
| 16 | RDEPENDS:${PN}:append = " \ |
| 17 | bare-metal-active \ |
| 18 | " |
| 19 | |
| 20 | SYSTEMD_PACKAGES = "${PN}" |
| 21 | SYSTEMD_SERVICE:${PN} = " \ |
| 22 | disable-ipmi-kcs.service \ |
| 23 | " |
| 24 | |
| 25 | # This should be aligned with the phosphor-ipmi-kcs and override per platform |
| 26 | KCS_DEVICE ?= "ipmi_kcs1" |
| 27 | |
| 28 | do_install:append() { |
| 29 | |
| 30 | sed ${WORKDIR}/disable-ipmi-kcs.service.in \ |
| 31 | -e "s#@KCS_DEV@#${KCS_DEVICE}#" \ |
| 32 | > ${WORKDIR}/disable-ipmi-kcs.service |
| 33 | |
| 34 | install -d ${D}${systemd_system_unitdir} |
| 35 | install -m 0644 ${WORKDIR}/disable-ipmi-kcs.service ${D}${systemd_system_unitdir} |
| 36 | } |