blob: 9824b8898de75817eedafe7a879edf2e407925bd [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Library for rendering SVG files"
2DESCRIPTION = "A small library to render Scalable Vector Graphics (SVG), \
3associated with the GNOME Project. It renders SVG files to Cairo surfaces. \
4Cairo is the 2D, antialiased drawing library that GNOME uses to draw things to \
5the screen or to generate output for printing."
6HOMEPAGE = "https://gitlab.gnome.org/GNOME/librsvg"
7BUGTRACKER = "https://gitlab.gnome.org/GNOME/librsvg/issues"
8
9LICENSE = "LGPL-2.1-or-later"
10LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
11 "
12
13SECTION = "x11/utils"
14DEPENDS = "cairo gdk-pixbuf glib-2.0 libxml2 pango python3-docutils-native"
15BBCLASSEXTEND = "native nativesdk"
16
Patrick Williamsac13d5f2023-11-24 18:59:46 -060017GNOMEBASEBUILDCLASS = "autotools"
Patrick Williams2a254922023-08-11 09:48:11 -050018inherit cargo_common gnomebase pixbufcache gobject-introspection rust vala gi-docgen cargo-update-recipe-crates
Patrick Williamse760df82023-05-26 11:10:49 -050019
20require ${BPN}-crates.inc
Patrick Williams92b42cb2022-09-03 06:53:57 -050021
22SRC_URI += "file://0001-Makefile.am-pass-rust-target-to-cargo-also-when-not-.patch \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060023 file://0001-Add-riscv32-support.patch;patchdir=../cargo_home/bitbake/linux-raw-sys-0.4.3 \
Patrick Williams92b42cb2022-09-03 06:53:57 -050024 "
25
Patrick Williams2a254922023-08-11 09:48:11 -050026SRC_URI[archive.sha256sum] = "5a328048a02d014645cd27f61140f4e0b11280fb2c7f2a21864fe0c59ac1ce88"
27
28UPSTREAM_CHECK_REGEX = "librsvg-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
Patrick Williams92b42cb2022-09-03 06:53:57 -050029
30# librsvg is still autotools-based, but is calling cargo from its automake-driven makefiles
31# so we cannot use cargo class directly, but still need bits and pieces from it
32# for cargo to be happy
33BASEDEPENDS:append = " cargo-native"
34
35export RUST_BACKTRACE = "full"
36export RUSTFLAGS
37
38export RUST_TARGET = "${RUST_HOST_SYS}"
39
40RUSTFLAGS:append:mips = " --cfg crossbeam_no_atomic_64"
41RUSTFLAGS:append:mipsel = " --cfg crossbeam_no_atomic_64"
42RUSTFLAGS:append:powerpc = " --cfg crossbeam_no_atomic_64"
Patrick Williams92b42cb2022-09-03 06:53:57 -050043
Patrick Williams92b42cb2022-09-03 06:53:57 -050044do_configure[postfuncs] += "cargo_common_do_configure"
45
46inherit rust-target-config
47
Patrick Williams92b42cb2022-09-03 06:53:57 -050048# rust-cross writes the target linker binary into target json definition without any flags.
49# This breaks here because the linker isn't going to work without at least knowing where
50# the sysroot is. So copy the json to workdir, and patch in the path to wrapper from rust class
51# which supplies the needed flags.
52do_compile:prepend() {
53 sed -ie 's,"linker": ".*","linker": "${RUST_TARGET_CC}",g' ${RUST_TARGETS_DIR}/${RUST_HOST_SYS}.json
54}
55
Andrew Geissler8f840682023-07-21 09:09:43 -050056CVE_STATUS[CVE-2018-1000041] = "not-applicable-platform: Issue only applies on Windows"
Patrick Williams92b42cb2022-09-03 06:53:57 -050057
58CACHED_CONFIGUREVARS = "ac_cv_path_GDK_PIXBUF_QUERYLOADERS=${STAGING_LIBDIR_NATIVE}/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders"
59
60PACKAGECONFIG ??= "gdkpixbuf"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060061PACKAGECONFIG:append:class-target = " ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'vala', '', d)}"
Patrick Williams92b42cb2022-09-03 06:53:57 -050062# The gdk-pixbuf loader
63PACKAGECONFIG[gdkpixbuf] = "--enable-pixbuf-loader,--disable-pixbuf-loader,gdk-pixbuf-native"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060064PACKAGECONFIG[vala] = "--enable-vala,--disable-vala"
Patrick Williams92b42cb2022-09-03 06:53:57 -050065
66do_install:append() {
67 # Loadable modules don't need .a or .la on Linux
68 rm -f ${D}${libdir}/gdk-pixbuf-2.0/*/loaders/*.a ${D}${libdir}/gdk-pixbuf-2.0/*/loaders/*.la
69}
70
71PACKAGES =+ "librsvg-gtk rsvg"
72FILES:rsvg = "${bindir}/rsvg* \
73 ${datadir}/pixmaps/svg-viewer.svg \
74 ${datadir}/themes"
75FILES:librsvg-gtk = "${libdir}/gdk-pixbuf-2.0/*/*/*.so \
76 ${datadir}/thumbnailers/librsvg.thumbnailer"
77RRECOMMENDS:librsvg-gtk = "gdk-pixbuf-bin"
78
79PIXBUF_PACKAGES = "librsvg-gtk"