blob: c0c76ce1bdcb505735190d5a35e223a954f2e82c [file] [log] [blame]
Xo Wang4ef18bf2016-10-24 18:44:49 -07001DESCRIPTION = "Command line tools for hardware device registers"
Patrick Venture75072092017-10-05 15:11:30 -07002HOMEPAGE = "https://github.com/jonmayergoogle/iotools"
Patrick Williamsd541ec52022-04-30 07:41:26 -05003LICENSE = "GPL-2.0-or-later"
Xo Wang4ef18bf2016-10-24 18:44:49 -07004LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
Brad Bishop3a3497c2018-03-30 12:27:37 -04005SRCREV = "8d928b3360246b8ead95b442ca3887ce8b8f942f"
Xo Wang4ef18bf2016-10-24 18:44:49 -07006PV = "v1.6+git${SRCPV}"
7
Ed Tanous9936f862022-09-19 09:13:20 -07008SRC_URI = "git://git@github.com/jonmayergoogle/iotools.git;protocol=https;branch=master"
Patrick Venturef5952ed2017-10-05 16:25:40 -07009
Xo Wang4ef18bf2016-10-24 18:44:49 -070010S = "${WORKDIR}/git"
Ed Tanous9936f862022-09-19 09:13:20 -070011SYSTEMD_SERVICE:${PN} += "iotools-setup.service"
12
13inherit obmc-phosphor-systemd
Xo Wang4ef18bf2016-10-24 18:44:49 -070014
15do_compile() {
16 # CC is overridden in the Makefile, so override it harder in the invocation
17 oe_runmake CC="${CC}" DEBUG="${DEBUG_BUILD-0}" STATIC=0
18}
Xo Wang4ef18bf2016-10-24 18:44:49 -070019# The "install" make target runs the binary to create links for subcommands.
20# The links are excessive and this doesn't work for cross compiling.
21do_install() {
22 install -d ${D}${sbindir}
23 install -m 0755 iotools ${D}${sbindir}
24}
Patrick Venturef5952ed2017-10-05 16:25:40 -070025
Ed Tanous9936f862022-09-19 09:13:20 -070026FILES:${PN} = "${sbindir}"