blob: 0f8f643bcca00688c4b302767de60604edbbe475 [file] [log] [blame]
Brad Bishop0e04b2e2019-05-13 13:45:49 -04001SUMMARY = "Generate fan control YAML from the MRW"
Brad Bishop0e04b2e2019-05-13 13:45:49 -04002LICENSE = "Apache-2.0"
Ed Tanous9936f862022-09-19 09:13:20 -07003DEPENDS = "mrw-native mrw-perl-tools-native"
4PROVIDES += "virtual/phosphor-fan-control-fan-config"
5PR = "r1"
6
7S = "${WORKDIR}"
Brad Bishop0e04b2e2019-05-13 13:45:49 -04008
9inherit allarch
10inherit phosphor-fan
11inherit mrw-xml
12
Brad Bishop0e04b2e2019-05-13 13:45:49 -040013do_compile() {
14 ${bindir}/perl-native/perl \
15 ${bindir}/gen_fan_zone_yaml.pl \
16 -i ${STAGING_DIR_NATIVE}${mrw_datadir}/${MRW_XML} \
17 -o fans.yaml
18}
Brad Bishop0e04b2e2019-05-13 13:45:49 -040019do_install() {
20 install -D fans.yaml ${D}${control_datadir}/fans.yaml
21}
22
Patrick Williams12fc9392021-08-06 09:16:53 -050023FILES:${PN} += "${control_datadir}/fans.yaml"