blob: d1deb86a33fdc34eb70e87d44b2598a1b6804ed8 [file] [log] [blame]
Brad Bishop0e04b2e2019-05-13 13:45:49 -04001# Provides the config file for the phosphor-fan-presence application.
2# The default config file is empty. To provide a real one,
3# append this recipe in a layer, add:
Patrick Williams12fc9392021-08-06 09:16:53 -05004# FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
Brad Bishop0e04b2e2019-05-13 13:45:49 -04005# and provide a config file.
Brad Bishop0e04b2e2019-05-13 13:45:49 -04006SUMMARY = "Config file for phosphor-fan-presence"
Brad Bishop0e04b2e2019-05-13 13:45:49 -04007LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04008LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Ed Tanous9936f862022-09-19 09:13:20 -07009PROVIDES += "virtual/phosphor-fan-presence-config"
10PR = "r1"
11
12SRC_URI = "file://config.yaml"
13
14S = "${WORKDIR}"
Brad Bishop0e04b2e2019-05-13 13:45:49 -040015
16inherit allarch
17inherit phosphor-fan
18
Brad Bishop0e04b2e2019-05-13 13:45:49 -040019do_install() {
20 install -D config.yaml ${D}${presence_datadir}/config.yaml
21}
22
Patrick Williams12fc9392021-08-06 09:16:53 -050023FILES:${PN} += "${presence_datadir}/config.yaml"