blob: 84e4bf1a9b88a2222483f355dae55eaf0534396e [file] [log] [blame]
Brad Bishop0e04b2e2019-05-13 13:45:49 -04001SUMMARY = "Generate fan presence YAML from the MRW"
Brad Bishop0e04b2e2019-05-13 13:45:49 -04002LICENSE = "Apache-2.0"
Ed Tanous9936f862022-09-19 09:13:20 -07003DEPENDS = "mrw-native mrw-perl-tools-native"
4PROVIDES += "virtual/phosphor-fan-presence-config"
5PR = "r1"
6
7S = "${WORKDIR}"
Brad Bishop0e04b2e2019-05-13 13:45:49 -04008
9inherit allarch
10inherit phosphor-fan
11inherit mrw-xml
12
Brad Bishop0e04b2e2019-05-13 13:45:49 -040013do_install() {
14 DEST=${D}${presence_datadir}
15 install -d ${DEST}
Brad Bishop0e04b2e2019-05-13 13:45:49 -040016 ${bindir}/perl-native/perl \
17 ${bindir}/gen_presence_yaml.pl \
18 -i ${STAGING_DIR_NATIVE}${mrw_datadir}/${MRW_XML} \
19 -o ${DEST}/config.yaml
20}
Ed Tanous9936f862022-09-19 09:13:20 -070021
22FILES:${PN} += "${presence_datadir}/config.yaml"