blob: 66d002042cc169e8cafc4ba0e170ca589fdfd800 [file] [log] [blame]
Milton D. Miller II0e775142016-01-20 14:57:54 -06001SUMMARY = "Phosphor OpenBMC pre-init scripts"
Gunnar Millse5b38602018-08-31 12:39:15 -05002DESCRIPTION = "Phosphor OpenBMC filesystem mount reference implementation."
Brad Bishopcd0ba722018-06-19 15:21:01 -04003LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Brad Bishopcd0ba722018-06-19 15:21:01 -04005PR = "r1"
Milton D. Miller II0e775142016-01-20 14:57:54 -06006
Milton D. Miller II0e775142016-01-20 14:57:54 -06007SRC_URI += "file://obmc-init.sh"
8SRC_URI += "file://obmc-shutdown.sh"
9SRC_URI += "file://obmc-update.sh"
10SRC_URI += "file://whitelist"
11
Ed Tanous9936f862022-09-19 09:13:20 -070012S = "${WORKDIR}"
13
14inherit allarch
15
Milton D. Miller II0e775142016-01-20 14:57:54 -060016do_install() {
Ed Tanous9936f862022-09-19 09:13:20 -070017 for f in init-download-url init-options
18 do
19 if test -e $f
20 then
21 install -m 0755 ${WORKDIR}/$f ${D}/$f
22 fi
23 done
Milton D. Miller II0e775142016-01-20 14:57:54 -060024 install -m 0755 ${WORKDIR}/obmc-init.sh ${D}/init
25 install -m 0755 ${WORKDIR}/obmc-shutdown.sh ${D}/shutdown
26 install -m 0755 ${WORKDIR}/obmc-update.sh ${D}/update
27 install -m 0644 ${WORKDIR}/whitelist ${D}/whitelist
28 install -d ${D}/dev
29 mknod -m 622 ${D}/dev/console c 5 1
30}
31
Ed Tanous9936f862022-09-19 09:13:20 -070032RDEPENDS:${PN} += "${VIRTUAL-RUNTIME_base-utils}"
33
Patrick Williams12fc9392021-08-06 09:16:53 -050034FILES:${PN} += " /init /shutdown /update /whitelist /dev "
35FILES:${PN} += " /init-options /init-download-url "