blob: 303a0ef07c65f860ce51716c93c9cd99e1b9019b [file] [log] [blame]
Andrew Jeffery1b77f28e2018-04-06 14:13:14 +09301SUMMARY = "Phosphor IPMI daemon configuration"
Brad Bishop75f03872018-11-03 09:41:57 -07002LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04003LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Ed Tanous9936f862022-09-19 09:13:20 -07004PR = "r1"
Andrew Jeffery1b77f28e2018-04-06 14:13:14 +09305
6SRC_URI = " \
7 file://cipher_list.json \
8 file://dcmi_cap.json \
9 file://dcmi_sensors.json \
10 file://dev_id.json \
11 file://power_reading.json \
AppaRao Puli225e91f2018-06-27 23:40:11 +053012 file://channel_access.json \
13 file://channel_config.json \
Patrick Venture8327bba2019-08-19 12:32:53 -070014 file://entity-map.json \
jayaprakash Mutyala7f427612020-01-31 08:50:13 +000015 file://cs_privilege_levels.json \
Andrew Jeffery1b77f28e2018-04-06 14:13:14 +093016 "
17
Ed Tanous9936f862022-09-19 09:13:20 -070018inherit allarch
Andrew Jeffery1b77f28e2018-04-06 14:13:14 +093019
20do_fetch[noexec] = "1"
21do_patch[noexec] = "1"
22do_configure[noexec] = "1"
23do_compile[noexec] = "1"
Andrew Jeffery1b77f28e2018-04-06 14:13:14 +093024do_install() {
25 install -d ${D}${datadir}/ipmi-providers
26 install -m 0644 -D ${WORKDIR}/cipher_list.json \
27 ${D}${datadir}/ipmi-providers/cipher_list.json
28 install -m 0644 -D ${WORKDIR}/dcmi_cap.json \
29 ${D}${datadir}/ipmi-providers/dcmi_cap.json
30 install -m 0644 -D ${WORKDIR}/dcmi_sensors.json \
31 ${D}${datadir}/ipmi-providers/dcmi_sensors.json
32 install -m 0644 -D ${WORKDIR}/dev_id.json \
33 ${D}${datadir}/ipmi-providers/dev_id.json
34 install -m 0644 -D ${WORKDIR}/power_reading.json \
35 ${D}${datadir}/ipmi-providers/power_reading.json
AppaRao Puli225e91f2018-06-27 23:40:11 +053036 install -m 0644 -D ${WORKDIR}/channel_access.json \
37 ${D}${datadir}/ipmi-providers/channel_access.json
38 install -m 0644 -D ${WORKDIR}/channel_config.json \
39 ${D}${datadir}/ipmi-providers/channel_config.json
Patrick Venture8327bba2019-08-19 12:32:53 -070040 install -m 0644 -D ${WORKDIR}/entity-map.json \
41 ${D}${datadir}/ipmi-providers/entity-map.json
jayaprakash Mutyala7f427612020-01-31 08:50:13 +000042 install -m 0644 -D ${WORKDIR}/cs_privilege_levels.json \
43 ${D}${datadir}/ipmi-providers/cs_privilege_levels.json
Andrew Jeffery1b77f28e2018-04-06 14:13:14 +093044}
Ed Tanous9936f862022-09-19 09:13:20 -070045
46FILES:${PN} = " \
47 ${datadir}/ipmi-providers/cipher_list.json \
48 ${datadir}/ipmi-providers/dcmi_cap.json \
49 ${datadir}/ipmi-providers/dcmi_sensors.json \
50 ${datadir}/ipmi-providers/dev_id.json \
51 ${datadir}/ipmi-providers/power_reading.json \
52 ${datadir}/ipmi-providers/channel_access.json \
53 ${datadir}/ipmi-providers/channel_config.json \
54 ${datadir}/ipmi-providers/entity-map.json \
55 ${datadir}/ipmi-providers/cs_privilege_levels.json \
56 "