blob: e4e169407d495df68b32593643745789aa5c9764 [file] [log] [blame]
Brad Bishop0a544b52017-01-28 12:51:42 -05001SUMMARY = "Generate inventory map for phosphor-ipmi-fru from an MRW."
Ed Tanous9936f862022-09-19 09:13:20 -07002DEPENDS += "mrw-native mrw-perl-tools-native"
3# TODO: remove this dependency after the MRW script
4# has been updated to not require the hostfw metadata.
5DEPENDS += "virtual/phosphor-ipmi-fru-hostfw-config"
6PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
Patrick Venture8f93a292018-10-26 09:58:28 -07007PV = "1.0+git${SRCPV}"
Ed Tanous9936f862022-09-19 09:13:20 -07008PR = "r1"
9
10S = "${WORKDIR}/git"
Brad Bishop0a544b52017-01-28 12:51:42 -050011
Brad Bishop0a544b52017-01-28 12:51:42 -050012inherit phosphor-ipmi-fru
Matt Spinler0a8ea632017-12-14 13:31:55 -060013inherit mrw-xml
Joseph Reynolds79809ea2021-02-26 15:37:31 -060014inherit native
Brad Bishop0a544b52017-01-28 12:51:42 -050015
Brad Bishop0a544b52017-01-28 12:51:42 -050016do_install() {
Brad Bishop0a544b52017-01-28 12:51:42 -050017 DEST=${D}${config_datadir}
18 install -d ${DEST}
Brad Bishop0a544b52017-01-28 12:51:42 -050019 ${bindir}/perl-native/perl \
20 ${bindir}/gen_ipmi_fru.pl \
Matt Spinler0a8ea632017-12-14 13:31:55 -060021 -i ${mrw_datadir}/${MRW_XML} \
Brad Bishop0a544b52017-01-28 12:51:42 -050022 -m ${hostfw_datadir}/config.yaml \
23 -o ${DEST}/config.yaml
24}
Ed Tanous9936f862022-09-19 09:13:20 -070025
26require phosphor-ipmi-fru.inc