blob: 60beb99db84d36af6074b49acf97850eb031d3f8 [file] [log] [blame]
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -06001SUMMARY = "FRU properties config for ipmi-fru-parser"
Brad Bishop75f03872018-11-03 09:41:57 -07002LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04003LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Ed Tanous9936f862022-09-19 09:13:20 -07004PROVIDES += "virtual/phosphor-ipmi-fru-properties"
5PR = "r1"
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -06006
Ratan Gupta338899a2017-03-30 14:32:02 +05307SRC_URI += "file://extra-properties.yaml"
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -06008
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -06009S = "${WORKDIR}"
10
Ed Tanous9936f862022-09-19 09:13:20 -070011inherit phosphor-ipmi-fru
12inherit native
13
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -060014do_install() {
15 # This recipe is supposed to create an output yaml file with
16 # FRU property values extracted from the MRW. This example recipe
17 # provides a sample output file.
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -060018 DEST=${D}${properties_datadir}
19 install -d ${DEST}
Ratan Gupta338899a2017-03-30 14:32:02 +053020 install extra-properties.yaml ${DEST}
Deepak Kodihalli48be0fd2017-02-20 04:55:20 -060021}