blob: 70b60f1f9a829dfbac7db0749e24425beb4fda0c [file] [log] [blame]
Tom Josephcf7e8492017-05-08 11:49:10 +05301SUMMARY = "Inventory to Sensor config for phosphor-host-ipmi"
Brad Bishop75f03872018-11-03 09:41:57 -07002LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04003LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Ed Tanous9936f862022-09-19 09:13:20 -07004DEPENDS += " \
5 mrw-native \
6 mrw-perl-tools-native \
7 "
8PROVIDES += "virtual/phosphor-ipmi-inventory-sel"
9PR = "r1"
10
11SRC_URI += "file://config.yaml"
12
13S = "${WORKDIR}"
Tom Josephcf7e8492017-05-08 11:49:10 +053014
Tom Josephcf7e8492017-05-08 11:49:10 +053015inherit phosphor-ipmi-host
Matt Spinler0a8ea632017-12-14 13:31:55 -060016inherit mrw-xml
Joseph Reynolds79809ea2021-02-26 15:37:31 -060017inherit native
Tom Josephcf7e8492017-05-08 11:49:10 +053018
Tom Josephcf7e8492017-05-08 11:49:10 +053019do_install() {
20 DEST=${D}${sensor_datadir}
21 install -d ${DEST}
Tom Josephcf7e8492017-05-08 11:49:10 +053022 ${bindir}/perl-native/perl \
23 ${bindir}/gen_ipmi_sel.pl \
Matt Spinler0a8ea632017-12-14 13:31:55 -060024 -i ${mrw_datadir}/${MRW_XML} \
Tom Josephcf7e8492017-05-08 11:49:10 +053025 -m config.yaml \
26 -o ${DEST}/invsensor.yaml
27}