blob: c83760c9b39eb88cd7b568f77bc42c2d94feeeee [file] [log] [blame]
Ratan Gupta3aa591f2017-03-06 17:05:11 +05301SUMMARY = "Sensor config for phosphor-host-ipmi"
Brad Bishop75f03872018-11-03 09:41:57 -07002LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04003LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Ratan Gupta3aa591f2017-03-06 17:05:11 +05304PROVIDES += "virtual/phosphor-ipmi-sensor-inventory"
Ed Tanous9936f862022-09-19 09:13:20 -07005PR = "r1"
Ratan Gupta3aa591f2017-03-06 17:05:11 +05306
7SRC_URI += "file://config.yaml"
8
9S = "${WORKDIR}"
10
Ed Tanous9936f862022-09-19 09:13:20 -070011inherit phosphor-ipmi-host
12inherit native
13
Ratan Gupta3aa591f2017-03-06 17:05:11 +053014do_install() {
15 # This recipe is supposed to create an output yaml file with
16 # sensor data extracted from the mrw.
17 # provides a sample output file.
Ratan Gupta65e6e472017-03-17 19:37:28 +053018 DEST=${D}${sensor_datadir}
Ratan Gupta3aa591f2017-03-06 17:05:11 +053019 install -d ${DEST}
20 install config.yaml ${DEST}/sensor.yaml
21}