blob: 0eca2ab4e1ef7ed78aea1a401b6f7ecf06554fc6 [file] [log] [blame]
Matt Spinlera48f7f62018-06-21 13:13:52 -05001SUMMARY = "Copy error yaml files to known path for elog parsing"
Matt Spinlera48f7f62018-06-21 13:13:52 -05002LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04003LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Ed Tanous9936f862022-09-19 09:13:20 -07004PV = "1.0+git${SRCPV}"
5PR = "r1"
6
7S = "${WORKDIR}/git"
Matt Spinlera48f7f62018-06-21 13:13:52 -05008
Matt Spinlera48f7f62018-06-21 13:13:52 -05009inherit phosphor-dbus-yaml
Joseph Reynolds79809ea2021-02-26 15:37:31 -060010inherit native
Matt Spinlera48f7f62018-06-21 13:13:52 -050011
Patrick Williams12fc9392021-08-06 09:16:53 -050012do_install:append() {
Matt Spinlera48f7f62018-06-21 13:13:52 -050013 SRC=${S}/xyz/openbmc_project/Led/
14 DEST=${D}${yaml_dir}/xyz/openbmc_project/Led/
15 install -d ${DEST}/Fru
16 install ${SRC}/*.errors.yaml ${DEST}
17 install ${SRC}/*.metadata.yaml ${DEST}
18 install ${SRC}/Fru/*.errors.yaml ${DEST}/Fru
19 install ${SRC}/Fru/*.metadata.yaml ${DEST}/Fru
20}
Ed Tanous9936f862022-09-19 09:13:20 -070021
22require phosphor-led-manager.inc