blob: d9da9779b71976e3822e3f6a24b802f7e53e5cb7 [file] [log] [blame]
Jason M. Billsc8659172018-10-26 14:07:48 -07001# SEL Logger has the ability to monitor and automatically log SEL records for
2# various types of events, but this is disabled by default. The following
3# flags can be set in a .bbappend to enable specific types of event
4# monitoring:
5#
6# SEL_LOGGER_MONITOR_THRESHOLD_EVENTS:
7# Monitors and logs SEL records for threshold sensor events
Ed Tanous9936f862022-09-19 09:13:20 -07008SUMMARY = "Journal IPMI SEL Logger"
9DESCRIPTION = "Utility to write IPMI SEL records to the journal"
Jason M. Billsc8659172018-10-26 14:07:48 -070010LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
William A. Kennington IIIc9851952021-07-29 17:57:30 -070012DEPENDS += " \
13 boost \
14 sdbusplus \
15 systemd \
William A. Kennington IIIc9851952021-07-29 17:57:30 -070016 "
Andrew Geissler5d860f62022-08-04 12:51:06 -050017SRCREV = "628058fadb9d4c35dbe2c9636f3e6e93767e9526"
William A. Kennington IIIc9851952021-07-29 17:57:30 -070018PACKAGECONFIG ??= ""
William A. Kennington IIIe5b39f62021-08-06 09:23:57 -070019PACKAGECONFIG[log-threshold] = "-Dlog-threshold=true,-Dlog-threshold=false,"
20PACKAGECONFIG[log-pulse] = "-Dlog-pulse=true,-Dlog-pulse=false,"
21PACKAGECONFIG[log-watchdog] = "-Dlog-watchdog=true,-Dlog-watchdog=false,"
22PACKAGECONFIG[log-alarm] = "-Dlog-alarm=true,-Dlog-alarm=false,"
23PACKAGECONFIG[send-to-logger] = "-Dsend-to-logger=true,-Dsend-to-logger=false,phosphor-logging"
Charles Boyer40e6cb62021-09-09 09:28:08 -050024PACKAGECONFIG[clears-sel] = "-Dclears-sel=true,-Dclears-sel=false"
Ed Tanous9936f862022-09-19 09:13:20 -070025PV = "0.1+git${SRCPV}"
26
27SRC_URI = "git://github.com/openbmc/phosphor-sel-logger.git;protocol=https;branch=master"
28
29S = "${WORKDIR}/git"
30SYSTEMD_SERVICE:${PN} += "xyz.openbmc_project.Logging.IPMI.service"
31
32inherit pkgconfig meson systemd