blob: b997b99750143bff9e086f6fcd9b9f84efdb0bb8 [file] [log] [blame]
Ed Tanous9936f862022-09-19 09:13:20 -07001LICENSE = "Apache-2.0"
2LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
3DEPENDS:prepend = "nodejs-native "
4SRCREV = "e16bb5c35893591eab048ae4ef646a9e5e2f7e94"
5PV = "1.0+git${SRCPV}"
Ed Tanous760881a2017-11-02 12:58:57 -07006# This recipe requires online access to build, as it uses NPM for dependency
7# management and resolution.
Patrick Venturee28f3872018-10-03 13:22:12 -07008PR = "r1"
Patrick Venturee28f3872018-10-03 13:22:12 -07009
Patrick Williamsbb99d222022-01-24 15:55:09 -060010SRC_URI = "git://github.com/openbmc/phosphor-webui.git;branch=master;protocol=https"
Ed Tanous9936f862022-09-19 09:13:20 -070011
Ed Tanous760881a2017-11-02 12:58:57 -070012S = "${WORKDIR}/git"
13
Ed Tanous760881a2017-11-02 12:58:57 -070014inherit allarch
15
Ed Tanous760881a2017-11-02 12:58:57 -070016do_compile () {
Ed Tanous065ecd62022-06-09 11:33:48 -070017 bbwarn "phosphor-webui is deprecated and has been replaced with webui-vue"
Ed Tanous760881a2017-11-02 12:58:57 -070018 cd ${S}
19 rm -rf node_modules
Jeremy Kerr31ea32d2019-05-31 09:38:04 +080020 npm --loglevel info --proxy=${http_proxy} --https-proxy=${https_proxy} install
Ed Tanous760881a2017-11-02 12:58:57 -070021 npm run-script build
22}
Ed Tanous760881a2017-11-02 12:58:57 -070023do_install () {
24 # create directory structure
25 install -d ${D}${datadir}/www
26 cp -r ${S}/dist/** ${D}${datadir}/www
27 find ${D}${datadir}/www -type f -exec chmod a=r,u+w '{}' +
28 find ${D}${datadir}/www -type d -exec chmod a=rx,u+w '{}' +
29}
30
Ed Tanous9936f862022-09-19 09:13:20 -070031FILES:${PN} += "${datadir}/www/*"