blob: 8c699a8b4451edecbe82355fe2034bb3241e6ff0 [file] [log] [blame]
Ratan Gupta07a08c92018-09-03 08:41:52 +05301SUMMARY = "NSS and PAM module for using LDAP as a naming service"
2DESCRIPTION = "\
3 daemon for NSS and PAM lookups using LDAP \
4 This package provides a daemon for retrieving user accounts and similar \
5 system information from LDAP. It is used by the libnss-ldapd and \
6 libpam-ldapd packages but is not very useful by itself. \
7 "
Ratan Gupta07a08c92018-09-03 08:41:52 +05308HOMEPAGE = "http://arthurdejong.org/nss-pam-ldapd/"
Ed Tanous9936f862022-09-19 09:13:20 -07009SECTION = "base"
Patrick Williamsd541ec52022-04-30 07:41:26 -050010LICENSE = "LGPL-2.1-or-later"
Ratan Gupta07a08c92018-09-03 08:41:52 +053011LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
Patrick Williams12fc9392021-08-06 09:16:53 -050012FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
Ed Tanous9936f862022-09-19 09:13:20 -070013DEPENDS += "libpam openldap krb5"
Ratan Gupta07a08c92018-09-03 08:41:52 +053014
15SRC_URI = "\
Ed Tanous9936f862022-09-19 09:13:20 -070016 http://arthurdejong.org/nss-pam-ldapd/${BPN}-${PV}.tar.gz \
17 file://nslcd.init \
18 file://nslcd.service \
19 "
Ratan Gupta07a08c92018-09-03 08:41:52 +053020SRC_URI[md5sum] = "8c99fdc54f4bf9aca8c5f53fdb1403ff"
21SRC_URI[sha256sum] = "ef7362e7f2003da8c7beb7bcc03c30494acf712625aaac8badc6e7eb16f3453f"
22
Ed Tanous9936f862022-09-19 09:13:20 -070023SYSTEMD_SERVICE:${PN} = "nslcd.service"
Ratan Gupta07a08c92018-09-03 08:41:52 +053024
Ed Tanous9936f862022-09-19 09:13:20 -070025inherit autotools
26inherit update-rc.d systemd
Ratan Gupta07a08c92018-09-03 08:41:52 +053027
28EXTRA_OECONF = "\
Ed Tanous9936f862022-09-19 09:13:20 -070029 --disable-pynslcd \
30 --libdir=${base_libdir} \
31 --with-pam-seclib-dir=${base_libdir}/security \
32 "
Ratan Gupta07a08c92018-09-03 08:41:52 +053033
Ed Tanous9936f862022-09-19 09:13:20 -070034do_install:append() {
35 install -D -m 0755 ${WORKDIR}/nslcd.init ${D}${sysconfdir}/init.d/nslcd
36 sed -i -e 's/^uid nslcd/# uid nslcd/;' ${D}${sysconfdir}/nslcd.conf
37 sed -i -e 's/^gid nslcd/# gid nslcd/;' ${D}${sysconfdir}/nslcd.conf
38 sed -i -e 's/^base dc=example,dc=com/base ${LDAP_DN}/;' ${D}${sysconfdir}/nslcd.conf
39 install -d ${D}${systemd_system_unitdir}
40 install -m 0644 ${WORKDIR}/nslcd.service ${D}${systemd_system_unitdir}
41}
42
43RDEPENDS:${PN} += "nscd"
Ratan Gupta07a08c92018-09-03 08:41:52 +053044
Patrick Williams12fc9392021-08-06 09:16:53 -050045FILES:${PN} += "${base_libdir}/security ${datadir}"
46FILES:${PN}-dbg += "${base_libdir}/security/.debug"
Ratan Gupta07a08c92018-09-03 08:41:52 +053047
Ed Tanous9936f862022-09-19 09:13:20 -070048CONFFILES:${PN} += "${sysconfdir}/nslcd.conf"
Ratan Gupta07a08c92018-09-03 08:41:52 +053049
50INITSCRIPT_NAME = "nslcd"
51INITSCRIPT_PARAMS = "defaults"
52
Ed Tanous9936f862022-09-19 09:13:20 -070053LDAP_DN ?= "dc=my-domain,dc=com"