blob: 0e6fce9c91392c21f43e63a8daed9b3856f87111 [file] [log] [blame]
Brad Bishop996bc452019-12-02 13:05:15 -05001DESCRIPTION = "Bluetooth library with attribute support"
2SECTION = "libs/network"
3
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://CMakeLists.txt;beginline=1;endline=20;md5=8d5efeb9189b60866baff80ff791bf00"
6
7DEPENDS = "bluez5 glib-2.0"
8DEPENDS += "glib-2.0-native"
9
10PV = "0.2+git${SRCPV}"
11
12SRC_URI = "git://github.com/labapart/gattlib.git"
13SRC_URI += "file://dbus-avoid-strange-chars-from-the-build-dir.patch"
14
15SRCBRANCH = "master"
16SRCREV = "c6a33252221dff904cf277e085e2ce70aced8788"
17
18S = "${WORKDIR}/git"
19
20PACKAGECONFIG[examples] = "-DGATTLIB_BUILD_EXAMPLES=ON,-DGATTLIB_BUILD_EXAMPLES=OFF"
21
22# Set this to force use of DBus API if Bluez version is older than 5.42
23PACKAGECONFIG[force-dbus] = "-DGATTLIB_FORCE_DBUS=TRUE,-DGATTLIB_FORCE_DBUS=FALSE"
24
25EXTRA_OECMAKE += "-DGATTLIB_BUILD_DOCS=OFF"
26
27inherit pkgconfig cmake
28
29FILES_${PN} = "${libdir}/* ${includedir}/*"
30FILES_${PN}-dev = "${includedir}/*"