blob: 07db82a605770e0e35d45c6de916cd118e44f882 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "interface to seccomp filtering mechanism"
2DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp."
3SECTION = "security"
4LICENSE = "LGPL-2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f"
6
Brad Bishop9a533952019-12-19 16:39:26 -05007SRCREV = "1b6cfd1fc0b7499a28c24299a93a80bd18619563"
Brad Bishopc342db32019-05-15 21:57:59 -04008
9SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.4 \
Brad Bishop9a533952019-12-19 16:39:26 -050010 file://0001-tests-rely-on-__SNR_xxx-instead-of-__NR_xxx-for-sysc.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040011 file://run-ptest \
12"
13
14S = "${WORKDIR}/git"
15
16inherit autotools-brokensep pkgconfig ptest
17
18PACKAGECONFIG ??= ""
19PACKAGECONFIG[python] = "--enable-python, --disable-python, python"
20
Brad Bishop1fdf4aa2019-09-09 14:56:41 -040021DISABLE_STATIC = ""
22
Brad Bishopc342db32019-05-15 21:57:59 -040023do_compile_ptest() {
24 oe_runmake -C tests check-build
25}
26
27do_install_ptest() {
28 install -d ${D}${PTEST_PATH}/tests
29 install -d ${D}${PTEST_PATH}/tools
30 for file in $(find tests/* -executable -type f); do
31 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
32 done
33 for file in $(find tests/*.tests -type f); do
34 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests
35 done
36 for file in $(find tools/* -executable -type f); do
37 install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools
38 done
39}
40
41FILES_${PN} = "${bindir} ${libdir}/${BPN}.so*"
42FILES_${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug"
43
44RDEPENDS_${PN}-ptest = "bash"