blob: ad1fda3f3b7572c62666157cc9bd62346e5628da [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Provides a way to load and enumerate PKCS#11 modules"
2DESCRIPTION = " Provides a standard configuration setup for installing PKCS#11 modules in such a way that they're discoverable. Also solves problems with coordinating the use of PKCS#11 by different components or libraries living in the same process."
3HOMEPAGE = "https://p11-glue.github.io/p11-glue/p11-kit.html"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50"
6
7inherit meson gettext pkgconfig gtk-doc bash-completion manpages
8
9DEPENDS = "libtasn1 libtasn1-native libffi"
10
11DEPENDS:append = "${@' glib-2.0' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
12
Andrew Geissler5082cc72023-09-11 08:41:39 -040013SRC_URI = "git://github.com/p11-glue/p11-kit;branch=master;protocol=https \
14 file://strerror-1.patch \
15 file://strerror-2.patch"
Andrew Geissler8f840682023-07-21 09:09:43 -050016SRCREV = "a8cce8bd8065bbf80bd47219f85f0cd9cf27dd0c"
Andrew Geissler595f6302022-01-24 19:11:47 +000017S = "${WORKDIR}/git"
18
19PACKAGECONFIG ??= ""
20PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native"
21PACKAGECONFIG[trust-paths] = "-Dtrust_paths=/etc/ssl/certs/ca-certificates.crt,,,ca-certificates"
22
23GTKDOC_MESON_OPTION = 'gtk_doc'
24
25FILES:${PN} += " \
26 ${libdir}/p11-kit-proxy.so \
27 ${libdir}/pkcs11/*.so \
28 ${libdir}/pkcs11/*.la \
29 ${systemd_user_unitdir}/*"
30
31# PN contains p11-kit-proxy.so, a symlink to a loadable module
32INSANE_SKIP:${PN} = "dev-so"
33
Andrew Geisslerc5535c92023-01-27 16:10:19 -060034BBCLASSEXTEND = "native nativesdk"