blob: 03b89b24550fb8caa6da9275b31d15218d59b77c [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001def gettext_dependencies(d):
2 if d.getVar('INHIBIT_DEFAULT_DEPS', True) and not oe.utils.inherits(d, 'cross-canadian'):
3 return ""
4 if d.getVar('USE_NLS', True) == 'no':
5 return "gettext-minimal-native"
6 return d.getVar('DEPENDS_GETTEXT', False)
7
8def gettext_oeconf(d):
9 if d.getVar('USE_NLS', True) == 'no':
10 return '--disable-nls'
11 # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set
12 if d.getVar('INHIBIT_DEFAULT_DEPS', True) and not oe.utils.inherits(d, 'cross-canadian'):
13 return '--disable-nls'
14 return "--enable-nls"
15
16DEPENDS_GETTEXT ??= "virtual/gettext gettext-native"
17
18BASEDEPENDS =+ "${@gettext_dependencies(d)}"
19EXTRA_OECONF_append = " ${@gettext_oeconf(d)}"