blob: 24eb87bafbea8734831715f72c358e91bfd20c39 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "ifupdown: basic ifup and ifdown used by initscripts"
2DESCRIPTION = "High level tools to configure network interfaces \
3This package provides the tools ifup and ifdown which may be used to \
4configure (or, respectively, deconfigure) network interfaces, based on \
5the file /etc/network/interfaces."
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
8
9SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/main/i/ifupdown/ifupdown_0.7.48.1ubuntu5.tar.gz \
10 file://defn2-c-man-don-t-rely-on-dpkg-architecture-to-set-a.patch \
11 file://inet-6-.defn-fix-inverted-checks-for-loopback.patch \
12 file://99_network \
13 "
14
15EXTRA_OEMAKE = ""
16
17# needed so we don't get default S="${WORKDIR}/ifupdown-${PV}"
18S = "${WORKDIR}/ifupdown-${PV}ubuntu5"
19
20
21inherit update-rc.d update-alternatives
22
23do_compile () {
24 chmod a+rx *.pl *.sh
25 oe_runmake 'CC=${CC}' "CFLAGS=${CFLAGS} -Wall -W -D'IFUPDOWN_VERSION=\"${PV}\"'"
26}
27
28do_install () {
29 install -d ${D}${mandir}/man8 \
30 ${D}${mandir}/man5 \
31 ${D}${base_sbindir}
32
33 # If volatiles are used, then we'll also need /run/network there too.
34 install -d ${D}/etc/default/volatiles
35 install -m 0644 ${WORKDIR}/99_network ${D}/etc/default/volatiles
36
37 install -m 0755 ifup ${D}${base_sbindir}/
38 ln ${D}${base_sbindir}/ifup ${D}${base_sbindir}/ifdown
39 install -m 0644 ifup.8 ${D}${mandir}/man8
40 install -m 0644 interfaces.5 ${D}${mandir}/man5
41 cd ${D}${mandir}/man8 && ln -s ifup.8 ifdown.8
42}
43
44ALTERNATIVE_PRIORITY = "100"
45ALTERNATIVE_${PN} = "ifup ifdown"
46
47ALTERNATIVE_LINK_NAME[ifup] = "${base_sbindir}/ifup"
48ALTERNATIVE_LINK_NAME[ifdown] = "${base_sbindir}/ifdown"
49
50INITSCRIPT_NAME = "ifup"
51INITSCRIPT_PARAMS = "start 39 S . stop 39 0 6 1 ."
52
53SRC_URI[md5sum] = "85ba375f3c6f26d34efb2a8575e77fc8"
54SRC_URI[sha256sum] = "08dce14692c07b72b583b86c4d3ace0d9dac1928925144cc3ddde15b694ebbdf"