blob: cfef03d2e86b1ce63d03f95e0d950efb52b95a28 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "C bindings for apps which will manipulate JSON data"
2DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C."
3HOMEPAGE = "https://github.com/json-c/json-c/wiki"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
6
7SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz \
8 file://0001-json_tokener-requires-INF-and-NAN.patch \
9 "
10
11SRC_URI[md5sum] = "3ca4bbb881dfc4017e8021b5e0a8c491"
12SRC_URI[sha256sum] = "000c01b2b3f82dcb4261751eb71f1b084404fb7d6a282f06074d3c17078b9f3f"
13
14RPROVIDES_${PN} = "libjson"
15
16inherit autotools
17
18do_configure_prepend() {
19 # Clean up autoconf cruft that should not be in the tarball
20 rm -f ${S}/config.status
21}