Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Generates traces of I/O traffic on block devices" |
| 2 | LICENSE = "GPLv2" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" |
| 4 | |
| 5 | DEPENDS = "libaio" |
| 6 | |
| 7 | SRCREV = "43fc870ce04e963def45dfc0d1ed4ea21ef10d4b" |
| 8 | |
| 9 | PV = "1.1.0+git${SRCPV}" |
| 10 | |
| 11 | SRC_URI = "git://git.kernel.dk/blktrace.git \ |
| 12 | file://ldflags.patch" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | EXTRA_OEMAKE = "\ |
| 17 | 'CC=${CC}' \ |
| 18 | 'CFLAGS=${CFLAGS}' \ |
| 19 | 'LDFLAGS=${LDFLAGS}' \ |
| 20 | " |
| 21 | |
| 22 | # There are a few parallel issues: |
| 23 | # 1) ../rbtree.o: error adding symbols: Invalid operation |
| 24 | # collect2: error: ld returned 1 exit status |
| 25 | # Makefile:42: recipe for target 'btt' failed |
| 26 | # 2) git/blkiomon.c:216: undefined reference to `rb_insert_color' |
| 27 | # collect2: error: ld returned 1 exit status |
| 28 | # Makefile:27: recipe for target 'blkparse' failed |
| 29 | # 3) ld: rbtree.o: invalid string offset 128 >= 125 for section `.strtab' |
| 30 | # 4) btreplay.o: file not recognized: File truncated |
| 31 | # collect2: error: ld returned 1 exit status |
| 32 | # btreplay/btreplay.c:47:18: fatal error: list.h: No such file or directory |
| 33 | PARALLEL_MAKE = "" |
| 34 | |
| 35 | do_install() { |
| 36 | oe_runmake ARCH="${ARCH}" prefix=${prefix} \ |
| 37 | mandir=${mandir} DESTDIR=${D} install |
| 38 | } |
| 39 | |