blob: aaeb33ffe97e3ad2e090f84d1be7d176545ced96 [file] [log] [blame]
Thang Q. Nguyen7d0f84a2021-09-23 06:47:52 +00001SUMMARY = "Phosphor OpenBMC Mt.Jade Platform Init Service"
2DESCRIPTION = "Phosphor OpenBMC Mt.Jade Platform Init Daemon"
3
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9inherit obmc-phosphor-systemd
10
11DEPENDS += "systemd"
12RDEPENDS:${PN} += "libsystemd"
13RDEPENDS:${PN} += "bash"
14
15SRC_URI = " \
16 file://ampere_platform_init.sh \
17 file://ampere-platform-init.service \
18 "
19
20SYSTEMD_PACKAGES = "${PN}"
21SYSTEMD_SERVICE:${PN} = "ampere-platform-init.service"
22
23do_install () {
24 install -d ${D}${sbindir}
25 install -m 0755 ${WORKDIR}/ampere_platform_init.sh ${D}${sbindir}/
26 install -d ${D}${systemd_unitdir}/system/
27 install -m 0644 ${WORKDIR}/ampere-platform-init.service ${D}${systemd_unitdir}/system
28}