blob: 51620bba8efa9e5e6037859be67a01da7661370a [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Folks is a contact aggregation library."
2LICENSE = "LGPL-2.1-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
4
5DEPENDS = " \
6 glib-2.0 \
7 libgee \
8"
9
10GNOMEBASEBUILDCLASS = "meson"
11EXTRA_OEMESON += "-Dtests=false"
12
13# gobject-introspection is mandatory and cannot be configured
14REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
15GIR_MESON_OPTION = ""
16
17PACKAGECONFIG[eds] = "-Deds_backend=true,-Deds_backend=false,evolution-data-server"
18PACKAGECONFIG[bluez] = "-Dbluez_backend=true,-Dbluez_backend=false,evolution-data-server"
19PACKAGECONFIG[ofono] = "-Deds_backend=true -Dofono_backend=true,-Dofono_backend=false,evolution-data-server"
20PACKAGECONFIG[telepathy] = "-Dtelepathy_backend=true,-Dtelepathy_backend=false,telepathy-glib dbus-glib"
21PACKAGECONFIG[import_tool] = "-Dimport_tool=true,-Dimport_tool=false,libxml2"
22PACKAGECONFIG[inspect_tool] = "-Dinspect_tool=true,-Dinspect_tool=false"
23
24PACKAGECONFIG ??= ""
25
26inherit pkgconfig gnomebase gettext gobject-introspection vala features_check
27
28SRC_URI[archive.sha256sum] = "0fff8a896330cd82aee4598324f7e541c884d0337536212723b4beb38c759086"