blob: a6e5fa03002c6e45b0abca5eaf09f7968f0923fb [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "GEGL (Generic Graphics Library) is a graph based image processing framework"
2LICENSE = "GPL-3.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=f1a8bfcbc85304df454b65d378b299c7"
4
5DEPENDS = " \
6 intltool-native \
7 babl \
8 glib-2.0 \
9 cairo \
10 expat \
11 zlib \
12 \
13 json-glib \
14"
15
16GNOMEBASEBUILDCLASS = "meson"
17
18inherit features_check gnomebase vala gobject-introspection
19
20REQUIRED_DISTRO_FEATURES = "x11"
21
22SHPV = "${@gnome_verdir("${PV}")}"
23
24SRC_URI = "https://download.gimp.org/pub/${BPN}/${SHPV}/${BP}.tar.xz"
25SRC_URI[sha256sum] = "6fd58a0cdcc7702258adaeffb573a389228ae8f0eff47578efda2309b61b2ca6"
26
27PACKAGECONFIG ??= "gexiv2 jpeg libpng libraw librsvg pango poppler sdl2"
28PACKAGECONFIG:class-native = "libpng librsvg"
29
30PACKAGECONFIG[jasper] = "-Djasper=enabled,-Djasper=disabled,jasper"
31PACKAGECONFIG[gexiv2] = "-Dgexiv2=enabled,-Dgexiv2=disabled,gexiv2"
32PACKAGECONFIG[graphviz] = "-Dgraphviz=enabled,-Dgraphviz=disabled,graphviz"
33PACKAGECONFIG[jpeg] = "-Dlibjpeg=enabled,-Dlibjpeg=disabled,jpeg"
34PACKAGECONFIG[lcms] = "-Dlcms=enabled,-Dlcms=disabled,lcms"
35PACKAGECONFIG[libav] = "-Dlibav=enabled,-Dlibav=disabled,libav"
36PACKAGECONFIG[libpng] = "-Dlibpng=enabled,-Dlibpng=disabled,libpng"
37PACKAGECONFIG[libraw] = "-Dlibraw=enabled,-Dlibraw=disabled,libraw"
38PACKAGECONFIG[librsvg] = "-Dlibrsvg=enabled,-Dlibrsvg=disabled,librsvg"
39PACKAGECONFIG[pango] = "-Dpango=enabled -Dpangocairo=enabled,-Dpango=disabled -Dpangocairo=disabled,pango"
40PACKAGECONFIG[poppler] = "-Dpoppler=enabled,-Dpoppler=disabled,poppler"
41PACKAGECONFIG[sdl] = "-Dsdl1=enabled,-Dsdl1=disabled,virtual/libsdl"
42PACKAGECONFIG[sdl2] = "-Dsdl2=enabled,-Dsdl2=disabled,virtual/libsdl2"
43PACKAGECONFIG[tiff] = "-Dlibtiff=enabled,-Dlibtiff=disabled,tiff"
44PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,webp"
45
46# There are a couple of non-symlink .so files installed into libdir, which need to go into main package
47FILES:${PN} += " \
48 ${libdir}/*.so \
49 ${libdir}/gegl-${SHPV}/*.json \
50 ${libdir}/gegl-${SHPV}/*.so \
51"
52FILES_SOLIBSDEV = "${libdir}/libgegl-${SHPV}${SOLIBSDEV}"
53
54# Fails to build with thumb-1 (qemuarm)
55# gegl-0.2.0/operations/common/matting-global.c: In function 'matting_process':
56# gegl-0.2.0/operations/common/matting-global.c:463:1: internal compiler error: in patch_jump_insn, at cfgrtl.c:1275
57ARM_INSTRUCTION_SET = "arm"
58
59BBCLASSEXTEND = "native"