blob: 6b3479c264d7bc303bc1bdd73c828e8c6d5e79a2 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Evince is a document viewer for document formats like pdf, ps, djvu"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=96f2f8d5ee576a2163977938ea36fa7b"
4SECTION = "x11/office"
5DEPENDS = " \
6 gnome-common-native \
7 yelp-tools-native \
8 appstream-glib \
9 gtk+3 \
10 gspell \
11 libsecret \
12 poppler \
13 gstreamer1.0-plugins-base \
14 orc \
15 adwaita-icon-theme \
16 libhandy \
17 ${@bb.utils.contains('DISTRO_FEATURES','x11','gnome-desktop','',d)} \
18"
19
20GNOMEBASEBUILDCLASS = "meson"
21
22inherit gnomebase itstool gnome-help pkgconfig gsettings gobject-introspection gettext mime-xdg gtk-doc
23
24def gnome_verdir(v):
25 return oe.utils.trim_version(v, 1)
26
27SRC_URI += " file://0001-Remove-incorrect-args-for-i18n.merge_file.patch"
28SRC_URI[archive.sha256sum] = "ff245240f230922bec32a4d7b0a1d91b247a83d13484f99b74035d51eb232130"
29
30GTKDOC_MESON_OPTION = "gtk_doc"
31
32EXTRA_OEMESON = " \
33 -Dsystemduserunitdir=no \
34"
35
36do_compile:prepend() {
37 export GIR_EXTRA_LIBS_PATH="${B}/libdocument/.libs"
38}
39
40PACKAGECONFIG ??= ""
41PACKAGECONFIG[nautilus] = "-Dnautilus=true,-Dnautilus=false,nautilus"
42
43RDEPENDS:${PN} += "glib-2.0-utils"
44RRECOMMMENDS_${PN} = "adwaita-icon-theme"
45
46PACKAGES =+ "${PN}-nautilus-extension"
47
48FILES:${PN} += "${datadir}/dbus-1 \
49 ${datadir}/metainfo \
50 ${datadir}/thumbnailers \
51"
52FILES:${PN}-nautilus-extension = "${libdir}/nautilus/*/*so"