blob: 1cdc96ba0b67199d2dd3b22a688301bdd7ee7482 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "GNOME Settings"
2DESCRIPTION = "GNOME Settings is GNOME's main interface for configuration of various aspects of your desktop"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00004LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e"
5
6GNOMEBASEBUILDCLASS = "meson"
7
8inherit gnomebase gsettings gettext vala upstream-version-is-even bash-completion features_check
9
10DEPENDS = " \
11 gdk-pixbuf-native \
12 colord-gtk \
13 udisks2 \
14 upower \
15 polkit \
16 pulseaudio \
17 accountsservice \
18 samba \
19 gsettings-desktop-schemas \
20 gnome-settings-daemon \
21 gnome-desktop \
22 gnome-online-accounts \
23 libnma \
24 gnome-bluetooth \
25 grilo \
26 libgtop \
27 gsound \
28 libpwquality \
29 libhandy \
30"
31
32REQUIRED_DISTRO_FEATURES += "polkit pulseaudio systemd x11"
33
34SRC_URI[archive.sha256sum] = "8271fc6b33ec2418a578304dd3e57d665f0d7cc706a99a97be419848618fe248"
35SRC_URI += "file://0001-Add-meson-option-to-pass-sysroot.patch"
36SRC_URI += " file://0001-meson-drop-unused-argument-for-i18n.merge_file.patch"
37
38PACKAGECONFIG ??= "ibus ${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}"
39PACKAGECONFIG[ibus] = "-Dibus=true, -Dibus=false, ibus"
40PACKAGECONFIG[wayland] = "-Dwayland=true, -Dwayland=false, wayland"
41
42# Once we have (lib)cheese we can make cheese a PACKAGECONFIG
43EXTRA_OEMESON = " \
44 -Doe_sysroot=${STAGING_DIR_HOST} \
45 -Dcheese=false \
46"
47
48do_install:append() {
49 # If polkit is setup fixup permissions and ownership
50 if [ -d ${D}${datadir}/polkit-1/rules.d ]; then
51 chmod 700 ${D}${datadir}/polkit-1/rules.d
52 chown polkitd:root ${D}${datadir}/polkit-1/rules.d
53 fi
54}
55
56FILES:${PN} += " \
57 ${datadir}/dbus-1 \
58 ${datadir}/gnome-shell \
59 ${datadir}/metainfo \
60"
61
62FILES:${PN}-dev += "${datadir}/gettext"
63
64RDEPENDS:${PN} += "gsettings-desktop-schemas"