blob: e9724748cac5134684b53d916daaad561d898f68 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "GNOME disk utility"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5SECTION = "x11/gnome"
6
7DEPENDS = " \
8 gtk+3 \
9 libdvdread \
10 libcanberra \
11 libnotify \
12 libsecret \
13 libpwquality \
14 udisks2 \
15 libhandy \
16"
17
18GNOMEBASEBUILDCLASS = "meson"
19
20inherit gnomebase gsettings gtk-icon-cache gettext features_check mime-xdg
21
22REQUIRED_DISTRO_FEATURES = "x11 polkit"
23
24PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
25
26# As soon as elogind is of interest this needs rework: meson option is combo
27PACKAGECONFIG[systemd] = "-Dlogind=libsystemd,-Dlogind=none,systemd"
28
29SRC_URI[archive.sha256sum] = "1b6564454d67426322cb3bfc5a5558653bfc7dfeea2ae0825b1d08629f01090b"
30
31EXTRA_OEMESON = "-Dman=false"
32
33FILES:${PN} += " \
34 ${datadir}/metainfo \
35 ${datadir}/dbus-1 \
36"