blob: 8dabb9e0c12bc98919818b4b65e5eb6192c4a30b [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "GNOME Online Accounts - Single sign-on framework for GNOME"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "LGPL-2.0-or-later"
Andrew Geisslereff27472021-10-29 15:35:00 -05003LIC_FILES_CHKSUM = "file://COPYING;md5=34c88b124db5fb2762c1676be7dadd36"
4
5GNOMEBASEBUILDCLASS = "autotools"
6
7inherit gnomebase gsettings gobject-introspection gsettings gtk-doc vala gettext features_check
8
9# for webkitgtk
10REQUIRED_DISTRO_FEATURES = "x11"
11
12DEPENDS = "glib-2.0"
13
Andrew Geissler595f6302022-01-24 19:11:47 +000014SRC_URI += "file://0001-Update-to-rest-1.0.patch"
Andrew Geisslereff27472021-10-29 15:35:00 -050015SRC_URI[archive.sha256sum] = "3bcb3663a12efd4482d9fdda3e171676267fc739eb6440a2b7109a0e87afb7e8"
16
17# backend is required for gnome-control-center
18PACKAGECONFIG = "backend other"
19
Andrew Geissler595f6302022-01-24 19:11:47 +000020PACKAGECONFIG[backend] = "--enable-backend,--disable-backend,gtk+3 webkitgtk libsoup-2.4 json-glib libsecret rest libxml2"
Andrew Geisslereff27472021-10-29 15:35:00 -050021PACKAGECONFIG[krb5] = "--enable-kerberos, --disable-kerberos , krb5 gcr"
22
23# no extra dependencies!
24PACKAGECONFIG[other] = " \
25 --enable-facebook --enable-foursquare --enable-exchange --enable-flickr --enable-google --enable-imap-smtp --enable-owncloud --enable-windows-live,\
26 --disable-facebook --disable-foursquare --disable-exchange --disable-flickr --disable-google --disable-imap-smtp --disable-owncloud --disable-windows-live, \
27"
28
29FILES:${PN} += " \
30 ${datadir}/dbus-1 \
31 ${libdir}/goa-1.0/web-extensions/*.so \
32"
33
34# looked into pkg-config file: it is not a bug - they mean it
35FILES:${PN}-dev += "${libdir}/goa-1.0/include"