blob: 8d0dba48400c9089c40d849d7981f7af1962c9dd [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "GNOME Shell is the graphical shell of the GNOME desktop environment"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00003LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5GNOMEBASEBUILDCLASS = "meson"
6
7inherit gnomebase gsettings gettext gobject-introspection features_check bash-completion
8
9REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
10
11DEPENDS = " \
12 libxml2-native \
13 sassc-native \
14 gtk4 \
15 mutter \
16 evolution-data-server \
17 gcr \
18 gjs \
19 gnome-autoar \
20 polkit \
21 libcroco \
22 startup-notification \
23 ibus \
24 gsettings-desktop-schemas \
25"
26
27GTKDOC_MESON_OPTION = "gtk_doc"
28GIR_MESON_OPTION = ""
29
30# gobject-introspection is mandatory and cannot be configured
31REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
32
33SRC_URI[archive.sha256sum] = "384651eb051393dbabe006d1ad057bf29d5cd73ebb87bc779ff5e1c31e80a827"
34SRC_URI += "file://0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch"
35SRC_URI += " file://0001-build-Drop-incorrect-positional-arg.patch"
36
37PACKAGECONFIG ??= "bluetooth nm ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
38PACKAGECONFIG[bluetooth] = ",,gnome-bluetooth"
39PACKAGECONFIG[nm] = "-Dnetworkmanager=true, -Dnetworkmanager=false, networkmanager"
40PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
41
42EXTRA_OEMESON = " \
43 -Dgjs_path=${bindir}/gjs \
44 -Dextensions-app:gjs_path=${bindir}/gjs \
45 -Dtests=false \
46 -Dman=false \
47"
48
49do_install:append() {
50 # fix shebangs
51 for tool in `find ${D}${bindir} -name '*-tool'`; do
52 sed -i 's:#!${PYTHON}:#!${bindir}/${PYTHON_PN}:' $tool
53 done
54}
55
56GSETTINGS_PACKAGE = "${PN}-gsettings"
57
58FILES:${PN} += " \
59 ${datadir}/metainfo \
60 ${datadir}/dbus-1 \
61 ${datadir}/gnome-control-center \
62 ${datadir}/xdg-desktop-portal \
63 ${systemd_user_unitdir} \
64"
65
66RDEPENDS:${PN} += "gnome-desktop gsettings-desktop-schemas gdm-base librsvg-gtk ${PN}-gsettings"
67
68PACKAGES =+ "${PN}-tools ${PN}-gsettings"
69FILES:${PN}-tools = "${bindir}/*-tool"
70RDEPENDS:${PN}-tools = "python3-core"
71