blob: 01427b157d1fb257bbe3cc18ee0703750e528689 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Help browser for the GNOME desktop"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00003LIC_FILES_CHKSUM = " \
4 file://COPYING;md5=6e1b9cb787e76d7e6946887a65caa754 \
5"
6
7inherit gnomebase itstool autotools-brokensep gsettings gettext gtk-doc features_check mime-xdg
8
9# for webkitgtk
10REQUIRED_DISTRO_FEATURES = "x11"
11
12SRC_URI[archive.sha256sum] = "b00bf033f02dd79b6d3f255031c71df8d6ed38e552c870b8f391a374724c43c5"
13
14DEPENDS += " \
15 libxml2-native \
16 glib-2.0-native \
17 gtk+3 \
18 appstream-glib \
19 libxslt \
20 sqlite3 \
21 webkitgtk \
22 yelp-xsl \
23"
24PACKAGECONFIG ?= ""
25
26# Enable if soup3 is enabled in webkit recipe
27PACKAGECONFIG[soup3] = ",--with-webkit2gtk-4-0,"
28
29do_configure:prepend() {
30 export ITSTOOL=${STAGING_BINDIR_NATIVE}/itstool
31}
32
33FILES:${PN} += " \
34 ${datadir}/metainfo \
35 ${datadir}/yelp-xsl \
36"
37
38RDEPENDS:${PN} += "yelp-xsl"