blob: 1811b2d3c46a7d79c2203961054db9d5f2d06304 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Tools for certain user account management tasks"
2DESCRIPTION = "The usermode contains the userhelper program, which can be used to allow configured \
3programs to be run with superuser privileges by ordinary users, and several \
4graphical tools for users: \
5* userinfo allows users to change their finger information. \
6* usermount lets users mount, unmount, and format filesystems. \
7* userpasswd allows users to change their passwords. \
8"
9HOMEPAGE = "https://pagure.io/usermode"
Andrew Geissler9aee5002022-03-30 16:27:02 +000010LICENSE = "GPL-2.0-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +000011LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
12
13DEPENDS = "libuser ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} \
14 gtk+ desktop-file-utils-native \
15 startup-notification intltool-native \
16 util-linux \
17"
18
19SRC_URI = "https://releases.pagure.org/${BPN}/${BPN}-${PV}.tar.xz \
20 file://0001-fix-compile-failure-against-musl-C-library.patch \
21 file://0001-Makefile.am-Link-with-libm-for-powl-API.patch \
22 "
23SRC_URI[sha256sum] = "e7f58712b12175965b3a21522052863a061f3f1a888df3ffbe713b434f80254f"
24
25REQUIRED_DISTRO_FEATURES = "x11 pam"
26
27inherit features_check autotools gettext pkgconfig
28
29EXTRA_OEMAKE += "INSTALL='install -p'"
30