blob: 38fafe82e45d1a0055896aa1e5f2599a69533bd2 [file] [log] [blame]
Brad Bishop93c3acf2019-10-29 09:48:15 -04001DESCRIPTION = "Gstreamer Daemon"
Brad Bishop316dfdd2018-06-25 12:45:53 -04002SUMMARY = "GStreamer framework for controlling audio and video streaming using TCP connection messages"
3HOMEPAGE = "https://developer.ridgerun.com/wiki/index.php?title=Gstd-1.0"
4SECTION = "multimedia"
Andrew Geissler9aee5002022-03-30 16:27:02 +00005LICENSE = "GPL-2.0-or-later"
Brad Bishop93c3acf2019-10-29 09:48:15 -04006LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
Brad Bishop316dfdd2018-06-25 12:45:53 -04007
Brad Bishope42b3e32020-01-15 22:08:42 -05008DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad gstreamer1.0-rtsp-server json-glib libdaemon jansson"
Brad Bishop316dfdd2018-06-25 12:45:53 -04009
10SRCBRANCH ?= "master"
Brad Bishope42b3e32020-01-15 22:08:42 -050011SRCREV = "a6621a5778b234651aa2adbbe304d906a3fa64d1"
Brad Bishop316dfdd2018-06-25 12:45:53 -040012SRC_URI = "git://git@github.com/RidgeRun/gstd-1.x.git;protocol=https;branch=${SRCBRANCH} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013 file://0001-gstd-yocto-compatibility.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040015S = "${WORKDIR}/git"
16
Brad Bishop93c3acf2019-10-29 09:48:15 -040017# Remove the +really when upstream version is > 1.0
Brad Bishope42b3e32020-01-15 22:08:42 -050018PV = "1.0+really0.8.0"
Brad Bishop93c3acf2019-10-29 09:48:15 -040019
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020inherit autotools pkgconfig gettext gtk-doc
Brad Bishop316dfdd2018-06-25 12:45:53 -040021
Patrick Williams213cb262021-08-07 19:21:33 -050022do_install:append() {
Andrew Geissler595f6302022-01-24 19:11:47 +000023 rmdir ${D}${localstatedir}/run/${BPN} ${D}${localstatedir}/run \
24 ${D}${localstatedir}/log/${BPN} ${D}${localstatedir}/log
25 rm -f ${D}${bindir}/gst-client ${D}${bindir}/gstd-client
Brad Bishope42b3e32020-01-15 22:08:42 -050026 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
27 install -d ${D}${sysconfdir}/tmpfiles.d
28 echo "d /run/${BPN} - - - -" \
29 > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
30 echo "d /${localstatedir}/log/${BPN} 0755 root root -" \
31 >> ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
32 fi
33 ln -sf gst-client-1.0 ${D}${bindir}/gst-client
34 ln -sf gst-client-1.0 ${D}${bindir}/gstd-client
Brad Bishop316dfdd2018-06-25 12:45:53 -040035}