blob: 601432682620346c94e8d80384fea6cc6b8ae0fa [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "download online streams into audio files"
2DESCRIPTION = "This command-line tool can be used to record MPEG III \
3and OGG online radio-streams into track-separated audio files."
4HOMEPAGE = "http://streamripper.sourceforge.net"
Andrew Geissler9aee5002022-03-30 16:27:02 +00005LICENSE = "GPL-2.0-only"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
7DEPENDS = "glib-2.0 libmad libogg libvorbis"
8
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009# While this item does not require it, it depends on libmad which does
10LICENSE_FLAGS = "commercial"
11
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012SRC_URI = "\
13 ${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \
14 file://0001-build-these-are-foreign-automake-projects.patch \
15 file://0002-build-don-t-ignore-CPPFLAGS-from-environment.patch \
16 file://0003-ripstream-fix-compilation.patch \
17"
18SRC_URI[mdsum] = "a37a1a8b8f9228522196a122a1c2dd32"
19SRC_URI[sha256sum] = "c1d75f2e9c7b38fd4695be66eff4533395248132f3cc61f375196403c4d8de42"
20
21inherit autotools pkgconfig
22
23EXTRA_OECONF += "--with-included-argv=yes --with-included-libmad=no"
24EXTRA_OECONF += "\
25 --with-ogg-includes=${STAGING_INCDIR} \
26 --with-ogg-libraries=${STAGING_LIBDIR} \
27 --with-vorbis-includes=${STAGING_INCDIR} \
28 --with-vorbis-libraries=${STAGING_LIBDIR} \
29"
30
31# the included argv library needs this
Patrick Williams213cb262021-08-07 19:21:33 -050032CPPFLAGS:append = " -DANSI_PROTOTYPES"