blob: ea06ee67f74973c031803e2c68d2ef9edbe5fd77 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "Blueman is a GTK+ Bluetooth Manager"
2LICENSE = "GPL-3.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
4
5DEPENDS = "gtk+3 glib-2.0 bluez5 python3-pygobject python3-cython-native"
6
7inherit meson gettext systemd gsettings pkgconfig python3native gtk-icon-cache
8
9SRC_URI = " \
10 https://github.com/blueman-project/blueman/releases/download/${PV}/blueman-${PV}.tar.xz \
11 file://0001-Search-for-cython3.patch \
12 file://0002-fix-fail-to-enable-bluetooth.patch \
13"
14SRC_URI[sha256sum] = "55d639feeda0b43b18a659e65985213a54b47dcb1348f3b4effb5238db242602"
15
16EXTRA_OEMESON = "-Druntime_deps_check=false -Dappindicator=false"
17
18SYSTEMD_SERVICE:${PN} = "${BPN}-mechanism.service"
19SYSTEMD_AUTO_ENABLE:${PN} = "disable"
20
21RRECOMENDS_${PN} += "adwaita-icon-theme"
22RDEPENDS:${PN} += " \
23 python3-core \
24 python3-dbus \
25 python3-pygobject \
26 python3-terminal \
27 packagegroup-tools-bluetooth \
28"
29
30PACKAGECONFIG ??= " \
31 ${@bb.utils.filter('DISTRO_FEATURES', 'polkit pulseaudio ', d)} \
32 thunar \
33"
34PACKAGECONFIG[thunar] = "-Dthunar-sendto=true,-Dthunar-sendto=false"
35PACKAGECONFIG[pulseaudio] = "-Dpulseaudio=true,-Dpulseaudio=false"
36PACKAGECONFIG[polkit] = "-Dpolicykit=true,-Dpolicykit=false"
37
38FILES:${PN} += " \
39 ${datadir} \
40 ${systemd_user_unitdir} \
41 ${PYTHON_SITEPACKAGES_DIR} \
42"
43
44# In code, path to python is a variable that is replaced with path to native version of it
45# during the configure stage, e.g ../recipe-sysroot-native/usr/bin/python3-native/python3.
46# Replace it with #!/usr/bin/env python3
47do_install:append() {
48 sed -i "1s/.*/#!\/usr\/bin\/env python3/" ${D}${prefix}/libexec/blueman-rfcomm-watcher \
49 ${D}${prefix}/libexec/blueman-mechanism \
50 ${D}${bindir}/blueman-adapters \
51 ${D}${bindir}/blueman-applet \
52 ${D}${bindir}/blueman-manager \
53 ${D}${bindir}/blueman-sendto \
54 ${D}${bindir}/blueman-services \
55 ${D}${bindir}/blueman-tray
56}
57