blob: 3e5fc91dad509e62a316ceeb45239031a23c718e [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Open source iec61850 implementation"
2DESCRIPTION = "IEC 61850 is an international standard for \
3communication systems in Substation Automation Systems \
4(SAS) and management of Decentralized Energy Resources \
5(DER). It is seen as one of the communication standards \
6of the emerging Smart Grid. \
7The project libIEC61850 provides a server and client \
8library for the IEC 61850/MMS, IEC 61850/GOOSE and IEC \
961850-9-2/Sampled Values communication protocols \
10written in C. It is available under the GPLv3 license."
11HOMEPAGE = "http://libiec61850.com"
12SECTION = "console/network"
13LICENSE = "GPL-3.0-only"
14LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
15DEPENDS = "swig-native python3"
16SRCREV = "210cf30897631fe2006ac50483caf8fd616622a2"
17
18SRC_URI = "git://github.com/mz-automation/${BPN}.git;branch=v1.5;protocol=https \
19 file://0001-pyiec61850-don-t-break-CMAKE_INSTALL_PATH-by-trying-.patch \
20 file://0001-pyiec61850-Use-CMAKE_INSTALL_LIBDIR-from-GNUInstallD.patch \
21"
22
23S = "${WORKDIR}/git"
24
25inherit cmake pkgconfig python3-dir python3native siteinfo
26
27EXTRA_OECMAKE = " \
28 -DBUILD_EXAMPLES=OFF \
29 -DBUILD_PYTHON_BINDINGS=ON \
30"
31
32RDEPENDS:${PN}-python = " python3-core "
33RDEPENDS:${PN} = " python3-core "
34
35FILES:${PN} += " \
36 ${libdir}/${PYTHON_DIR}/site-packages/iec61850.py \
37 ${libdir}/${PYTHON_DIR}/site-packages/_iec61850.so \
38"