blob: 7c37fc1676f3bf2eb63fa24b54e08652d8297b7f [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Virtual EtherDrive blade AoE target"
2SECTION = "admin"
3
Andrew Geissler9aee5002022-03-30 16:27:02 +00004LICENSE = "GPL-2.0-only"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05005LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6
Brad Bishopc342db32019-05-15 21:57:59 -04007UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/aoetools/files/vblade/"
8
Andrew Geissler72956ed2021-01-08 16:11:14 -06009SRCREV = "5f1a0ba8b9815e3f08a3e2635a17f78bbf2a5b10"
Andrew Geissler595f6302022-01-24 19:11:47 +000010SRC_URI = "git://github.com/OpenAoE/vblade;branch=master;protocol=https \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050011 file://cross.patch \
12 file://makefile-add-ldflags.patch \
13 file://${BPN}.conf \
14 file://${BPN}.init \
15 file://${BPN}.service \
16 file://volatiles.99_vblade \
17 "
18
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050019S = "${WORKDIR}/git"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050020
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050021UPSTREAM_CHECK_URI = "https://github.com/OpenAoE/vblade/archive/"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080022
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023inherit autotools-brokensep update-rc.d systemd
24
25do_install() {
26 install -D -m 0755 ${S}/vblade ${D}/${sbindir}/vblade
27 install -D -m 0755 ${S}/vbladed ${D}/${sbindir}/vbladed
28 install -D -m 0644 ${S}/vblade.8 ${D}/${mandir}/man8/vblade.8
29
30 install -D -m 0644 ${WORKDIR}/${BPN}.conf ${D}/${sysconfdir}/${BPN}.conf
31 install -D -m 0755 ${WORKDIR}/${BPN}.init ${D}/${sysconfdir}/init.d/${BPN}
32
33 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
34 install -d ${D}/${sysconfdir}/default/volatiles
35 install -m 0755 ${WORKDIR}/volatiles.99_vblade ${D}/${sysconfdir}/default/volatiles/99_vblade
36 fi
37
38 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
39 install -d ${D}/${bindir}
40 install -m 0755 ${WORKDIR}/${BPN}.init ${D}/${bindir}/
41 install -d ${D}${sysconfdir}/tmpfiles.d
42 echo "d /var/run/${BPN} 0755 root root -" > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
43
44 install -d ${D}${systemd_system_unitdir}
45 install -m 0644 ${WORKDIR}/vblade.service ${D}${systemd_system_unitdir}
46 sed -e 's,@BINDIR@,${bindir},g' -i ${D}${systemd_system_unitdir}/*.service
47 fi
48
49}
50
51INITSCRIPT_NAME = "vblade"
52INITSCRIPT_PARAMS = "start 30 . stop 70 0 1 2 3 4 5 6 ."
53
Patrick Williams213cb262021-08-07 19:21:33 -050054SYSTEMD_SERVICE:${PN} = "vblade.service"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050055SYSTEMD_AUTO_ENABLE = "disable"