blob: fd8e26ed1a5c9902711efde32b0d49044e544453 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Netfilter Tables userspace utillites"
2SECTION = "net"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d1a78fdd879a263a5e0b42d1fc565e79"
5
6DEPENDS = "libmnl libnftnl bison-native \
7 ${@bb.utils.contains('PACKAGECONFIG', 'mini-gmp', '', 'gmp', d)}"
8
9# Ensure we reject the 0.099 version by matching at least two dots
10UPSTREAM_CHECK_REGEX = "nftables-(?P<pver>\d+(\.\d+){2,}).tar.bz2"
11
12SRC_URI = "http://www.netfilter.org/projects/nftables/files/${BP}.tar.bz2 \
13 file://0001-examples-compile-with-make-check-and-add-AM_CPPFLAGS.patch \
14 "
15
16SRC_URI[sha256sum] = "0b28a36ffcf4567b841de7bd3f37918b1fed27859eb48bdec51e1f7a83954c02"
17
18inherit autotools manpages pkgconfig
19
20PACKAGECONFIG ??= "python readline json"
21PACKAGECONFIG[json] = "--with-json, --without-json, jansson"
22PACKAGECONFIG[manpages] = "--enable-man-doc, --disable-man-doc, asciidoc-native"
23PACKAGECONFIG[mini-gmp] = "--with-mini-gmp, --without-mini-gmp"
24PACKAGECONFIG[python] = "--enable-python --with-python-bin=${PYTHON}, --with-python-bin="", python3"
25PACKAGECONFIG[readline] = "--with-cli=readline, --without-cli, readline"
26PACKAGECONFIG[xtables] = "--with-xtables, --without-xtables, iptables"
27
28inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
29
30RRECOMMENDS:${PN} += "kernel-module-nf-tables"
31
32PACKAGES =+ "${PN}-python"
33FILES:${PN}-python = "${nonarch_libdir}/${PYTHON_DIR}"
34RDEPENDS:${PN}-python = "python3-core python3-json ${PN}"