blob: 816e513a157459d0ce32cab68f0494de7e30ff0f [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "OpenSource WebSocket Toolkit"
2DESCRIPTION = "noPoll is a OpenSource WebSocket implementation (RFC 6455), \
3written in ansi C, that allows building pure WebSocket solutions or to \
4provide WebSocket support to existing TCP oriented applications.\
5\
6noPoll provides support for WebSocket (ws://) and TLS (secure) WebSocket (wss://),\
7allowing message based (handler notified) programming or stream oriented access."
8
9HOMEPAGE = "http://www.aspl.es/nopoll/"
Andrew Geissler9aee5002022-03-30 16:27:02 +000010LICENSE = "LGPL-2.1-only"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011LIC_FILES_CHKSUM = "file://COPYING;md5=f0504124678c1b3158146e0630229298 \
12 "
13DEPENDS = "openssl"
14SRC_URI = "http://www.aspl.es/nopoll/downloads/nopoll-${PV}.tar.gz \
15 "
16SRC_URI[md5sum] = "8d333f158b5d5a8975a6149e6ef8db63"
17SRC_URI[sha256sum] = "7f1b20f1d0525f30cdd2a4fc386d328b4cf98c6d11cef51fe62cd9491ba19ad9"
18
19inherit autotools pkgconfig
20
21EXTRA_OECONF += "--disable-nopoll-doc"
22
23LDFLAGS += "-lpthread"