blob: 9a0292eacc635efb1a19a2cad7b45ec2f2b75c49 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Crontab entry to provide weekly updates of the GeoIP free databases."
2DESCRIPTION = "update databases for GeoIP"
3
4HOMEPAGE = "http://dev.maxmind.com/geoip/"
5SECTION = "net"
6
7DEPENDS = "zlib curl"
8
9SRC_URI = "https://github.com/maxmind/geoipupdate/releases/download/v2.5.0/geoipupdate-2.5.0.tar.gz \
10 file://GeoIP.conf \
11 file://geoipupdate.cron \
12 "
13SRC_URI[md5sum] = "28f633c49ec87ab01ad3c0fb0228a696"
14SRC_URI[sha256sum] = "5119fd0e338cd083e886228b26679c64bcbaade8a815be092aecf865a610ab26"
15
Andrew Geissler9aee5002022-03-30 16:27:02 +000016LICENSE = "GPL-2.0-only"
Brad Bishop316dfdd2018-06-25 12:45:53 -040017
18LIC_FILES_CHKSUM = "\
19file://ChangeLog.md;md5=11d2e31df0de2be3ccc3e2286c4dafcb \
20"
Patrick Williams213cb262021-08-07 19:21:33 -050021FILES:${PN} = "/usr/share/GeoIP \
Brad Bishop316dfdd2018-06-25 12:45:53 -040022 /etc/GeoIP.conf \
23 /etc/cron.d/geoipupdate.cron \
24 /usr/bin/geoipupdate \
25"
26inherit autotools
27
Patrick Williams213cb262021-08-07 19:21:33 -050028do_install:append() {
Brad Bishop316dfdd2018-06-25 12:45:53 -040029 install -d ${D}/${sysconfdir}
30 install -d ${D}/${sysconfdir}/cron.d
31 install ${WORKDIR}/GeoIP.conf ${D}/${sysconfdir}/
32 install ${WORKDIR}/geoipupdate.cron ${D}/${sysconfdir}/cron.d/
33}