blob: d4f76850d350f6d24449c0ee3902762b72dc69a4 [file] [log] [blame]
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07001SUMMARY = "HTTP request/response parser for C"
2DESCRIPTION = "This is a parser for HTTP messages written in C. It parses \
3 both requests and responses. The parser is designed to be used \
4 in performance HTTP applications. It does not make any \
5 syscalls nor allocations, it does not buffer data, it can be \
6 interrupted at anytime. Depending on your architecture, it \
7 only requires about 40 bytes of data per message stream (in a \
8 web server that is per connection)."
9AUTHOR = "Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com>"
10HOMEPAGE = "https://github.com/nodejs/http-parser"
11SECTION = "libs"
12LICENSE = "MIT"
13LIC_FILES_CHKSUM = "file://LICENSE-MIT;md5=9bfa835d048c194ab30487af8d7b3778"
14
Andrew Geissler595f6302022-01-24 19:11:47 +000015SRC_URI = "git://github.com/nodejs/http-parser.git;branch=master;protocol=https"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070016SRCREV = "2343fd6b5214b2ded2cdcf76de2bf60903bb90cd"
17
18S = "${WORKDIR}/git"
19
Andrew Geissler9aee5002022-03-30 16:27:02 +000020EXTRA_OEMAKE = "PLATFORM=linux"
21
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070022do_configure[noexec] = "1"
23
24do_compile() {
25 oe_runmake library package
26}
27
28do_install() {
Andrew Geissler9aee5002022-03-30 16:27:02 +000029 oe_runmake install DESTDIR=${D} PREFIX=${prefix} LIBDIR=${libdir}
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070030}
31
32BBCLASSEXTEND = "native nativesdk"