blob: 231c57260ea0480f2da076373037ea51685c1630 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "SMTP client library"
2DESCRIPTION = "LibESMTP is a library to manage posting \
3(or submission of) electronic mail using SMTP to a \
4preconfigured Mail Transport Agent (MTA) such as Exim or PostFix."
5HOMEPAGE = "https://libesmtp.github.io/"
6LICENSE = "LGPL-2.0-or-later"
7SECTION = "libs"
8
9DEPENDS = "openssl"
10
11SRC_URI = "git://github.com/libesmtp/libESMTP.git;branch=master;protocol=https"
12SRCREV = "1d0af244310a66943ab400be56b15a9087f181eb"
13
14S = "${WORKDIR}/git"
15
16LIC_FILES_CHKSUM = "file://LICENSE;md5=1803fa9c2c3ce8cb06b4861d75310742 \
17 file://COPYING.GPL;md5=393a5ca445f6965873eca0259a17f833"
18
19inherit meson pkgconfig
20
21EXTRA_OEMESON = " \
22 -Dpthreads=enabled \
23 -Dtls=enabled \
24 -Dxdg=false \
25 -Dlwres=disabled \
26 -Dbdat=true \
27 -Detrn=true \
28 -Dxusr=true \
29"
30
31FILES:${PN} = "${libdir}/lib*${SOLIBS} \
32 ${libdir}/esmtp-plugins-6.2.0/*${SOLIBSDEV}"