blob: 004330e1b4cf5cb78b82c3b25bf114f0ad7c5b61 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001DESCRIPTION = "Netsniff-ng is a fast zero-copy analyzer, pcap capturing and replaying tool"
2HOMEPAGE = "http://netsniff-ng.org"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-2.0-only"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00004LIC_FILES_CHKSUM = "file://COPYING;md5=9dd40dfb621eed702c0775577fbb7011"
5DEPENDS = "libpcap"
6
7SRCREV = "be3e706f00295024ebc199e70177343fdaebbc9e"
8SRC_URI = " \
9 git://github.com/netsniff-ng/netsniff-ng.git;protocol=https;branch=master \
10 file://0001-Cmds-automatically-create-folder.patch \
11 "
12
13S = "${WORKDIR}/git"
14
15inherit pkgconfig
16
17EXTRA_OEMAKE += " TERM='' "
18
19PACKAGECONFIG ??= ""
20PACKAGECONFIG[zlib] = ",--disable-zlib,zlib,"
21PACKAGECONFIG[libnl] = ",--disable-libnl,libnl,"
22PACKAGECONFIG[geoip] = ",--disable-geoip,geoip,"
23
24do_configure() {
25 ./configure --prefix=${prefix}
26}
27
28do_compile() {
29 oe_runmake
30}
31
32do_install() {
33 oe_runmake DESTDIR=${D} netsniff-ng_install
34}
35
36BBCLASSEXTEND = "native nativesdk"